Erratic Airport behaviour

Discussion in 'Mac Basics and Help' started by Will Cheyney, Sep 8, 2007.

  1. Will Cheyney macrumors 6502a

    Will Cheyney

    Joined:
    Jul 13, 2005
    Location:
    United Kingdom
    #1
    I have just received my 24" iMac and there seem to be come problems with the Airport.
    Sometimes when I try to join my network, I am told there was an 'error joining the network. Other times it works just fine. If also find that if I keep turning Airport off and then selecting the network, eventually it will connect.
    Its annoying because every time I restart the computer or wake it from sleep, the problem arises again.


    I have a Netgear router (DG834PN) and have had no trouble with it before. There are 6 other Macs in our house and this is the only machine to have trouble. Might also be worth mentioning that I have full wireless signal strength.


    Anyone have any idea what the problem might be?
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Have you tried using a different form of encryption, assuming its a protected network? :)
     
  3. Will Cheyney thread starter macrumors 6502a

    Will Cheyney

    Joined:
    Jul 13, 2005
    Location:
    United Kingdom
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    Weird. Try changing your router's broadcast channel. :)
     

Share This Page