Erratic Mouse

Discussion in 'iMac' started by exupery, Apr 13, 2015.

  1. exupery macrumors member

    exupery

    Joined:
    Jan 26, 2013
    #1
    I am running System Version 10.8.5 on a 21 inch IMac and lately my mouse seems to be unsmooth and erratic, sometimes jumping to other parts of the screen. It is a wireless mouse that came with the computer when I bought it (3)? years ago.
    Very annoying. From what I can see in a quick search I am not the only person suffering from this. Wish I could fix it since a lot of what I do requires some degree of smoothness from my mouse.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Have you tried replacing the batteries? Also, it's possible the mouse is dying, as they don't last forever.
     
  3. exupery thread starter macrumors member

    exupery

    Joined:
    Jan 26, 2013
    #3
    Yes, just replaced the batteries. Actually sometimes it seems worse than others.
    Maybe it should be replaced.
     
  4. matreya macrumors 65816

    matreya

    Joined:
    Nov 14, 2009
    #4
    Have you cleaned the surface the mouse is tracking on? Because over time, little spots of dust accumulate into larger spots and start affecting the way the mouse tracks.
     
  5. hfg macrumors 68040

    hfg

    Joined:
    Dec 1, 2006
    Location:
    Cedar Rapids, IA. USA
    #5
    Turn the mouse over and blow the lint out of the opening where the tracking receptor is located. :)

    I assume, given the age of your iMac, that it does not have USB 3.0 ports? They can cause mouse tracking problems under some circumstances.
     
  6. garyleecn macrumors 6502a

    Joined:
    Jul 25, 2014
    #6
    i have the very same problem on my 5k iMac. two magic mouses and one trackpad has exactly the same issue. took it to two genius bars, they couldn't find out the problem. then i contacted apple care, have them forwarded my diagnostics files to engineering team, and they figured that there was something wrong in the firmware, and antenna. they asked me to bring my iMac to genius bar and swap the whole logic board.


    but right before i was going to book an appointment for genius bar, 10.10.3 came out and i don't know how, fixed the problem.
     
  7. Toltepeceno Suspended

    Toltepeceno

    Joined:
    Jul 17, 2012
    Location:
    SMT, Edo MX, MX
    #7
    If you are connecting to the internet by wifi I would go into router settings and set the channel to stationary 1 or the highest, 11 or whatever, and eliminate that possibility. Sometimes wifi can play havoc with bluetooth especially when on auto channel.
     
  8. exupery thread starter macrumors member

    exupery

    Joined:
    Jan 26, 2013
    #8
    change channels?

    We have a cisco wi fi and I have read about changing channels but where do I go to do that?
     

Share This Page