Erratic Trackpad

Discussion in 'MacBook Pro' started by SenileTomato, May 5, 2014.

  1. SenileTomato macrumors member

    Joined:
    Mar 31, 2014
    Location:
    Montclair, NJ
    #1
    So after using my MPB Retina today, all of a sudden I noticed erratic movements as well as non-responsiveness with my trackpad. To my recollection, no liquids in the slightest have touched the trackpad nor the keyboard for that matter. Any idea of why this might be happening? I do have coverage for the laptop, but unfortauntely this is an older model (Nvidia 650M 1gb dedicated), and they no longer sell these. And from my experience, they usually do not repair older models.
     
  2. leman macrumors 604

    Joined:
    Oct 14, 2008
    #2
    They probably won't repair a 10 year old computer (because they won't have any parts for it), but they will certainly repair a computer they used to sell just a year ago. I think the hardware supports ends after 6 or so years with Apple, which is a quite reasonable timespan.
     
  3. DaveWickline, Jul 19, 2014
    Last edited: Jul 19, 2014

    DaveWickline macrumors newbie

    Joined:
    Jul 19, 2014
    #3
    This has to be a software glitch......this is how I fixed mine

    I have an Apple Pro 13-inch laptop tied to a wireless Apple Magic Trackpad, wireless Apple keyboard, 2-TB external Apple hard drive, Apple External either-net modem tied with an Apply HD 27-inch LED-backlit display with built-in, high-speed Thunderbolt I/O. The system has worked amazing for several years. Until recently that is when my external wireless Apple Magic Trackpad starting skipping and became difficult to control. I tried many things to fix this and came upon a suggestion that sounded strange but worked like a charm.

    I switched the language preference from English to Spanish and deleted the English preference. This requires a full reboot. Then I reversed it back to English and removed the Spanish. After that final reboot, my trackpad worked like it was brand new and was back to its amazing smooth self.

    While I cannot explain why this fixed the problem I am left to believe that resetting in language means it was some kind of a software glitch which self corrected by switching language preferences. It certainly is not hardware or interference from anything else.

    I hope this same workaround helps you solve your trackpad issue.

    Dave :)
     
  4. jdelgado macrumors regular

    Joined:
    Oct 25, 2009
    #4
    I had a similar issue with 15in 2010 MBP and a 15in 2012 MBP, but with the built-in trackpad. I solved the problem by repairing permissions. No idea why it worked, but this fixed the problem.
     
  5. jozeppy26 macrumors 6502

    jozeppy26

    Joined:
    Jul 8, 2008
    Location:
    St. Louis
    #5
    I had this same issue JUST happen. I was filling out some form online in Safari when all of a sudden my trackpad stopped working properly. The mouse jumped around, moved on its own, clicked random portions of the screen, enabled gestures on its own, and haphazardly responded to my inputs. Luckily, I have a bluetooth MagicMouse that I was able to use. I was worried it was an OS X Yosemite bug (I'm currently running the latest developer preview).

    Repairing permissions solved the problem!!! You're a life-saver man.
     
  6. TheHessian macrumors newbie

    Joined:
    Dec 13, 2014
    #6
    How I solved My "Runaway Trackpad" issue

    Try This: Put something in the trash (that you don't need;).
    Instead of clicking on "Empty Trash", Click on "Secure Empty Trash" (Under "Finder") You may find that extra files will be thrown away that were otherwise unknown to you, and therefore remaining in the trash bin, as was the case with my Mac Pro. I continue to "Take out the trash" that way every once in awhile, and sometimes find the same results even when my Mac has no apparent ongoing issues. I suspect "Adobe Flash Player" may have been the culprit. Good Luck.
     

Share This Page