Error 0xE8000002E

Discussion in 'iPhone' started by ScottNWDW, Aug 11, 2008.

  1. ScottNWDW macrumors 65816

    ScottNWDW

    Joined:
    Jul 10, 2008
    Location:
    Orlando, Florida
    #1
    :mad:
    Ever since I downloaded version 2.01 I am unable to update any of the programs on my iPhone 3G. When I try to update on the phone, because the app store says there is n update, it downloads, but is unable to install and states that I should update and install through iTunes.

    When I go to iTunes, I get the error message after syncing that the following items were unable to be installed on my iPhone, and then it lists the apps that were not installed. It's up to 4 apps now....

    Beijing 2008
    Five Dice
    Pageonce
    Splash ID

    Any insights as to why would be greatly appreciated.
     
  2. oursfan macrumors member

    Joined:
    Nov 28, 2007
    #2
    I have had the same issues and do not understand what is going on. I had some other issues with some software malfunctions that occurred on my phone last week and had to take the phone into the apple store to get a new one and thought that this may have been part of my problem then because it started happening last week before I got a replacement phone. However, I am still getting the same error messages on a brand new phone.

    Hopefully this will be fixed with a new update soon.
     
  3. Henk van Ess macrumors newbie

    Joined:
    Aug 20, 2008
    Location:
    Amsterdam
    #3
    There are suggestions on the web how to solve this. I tried:

    http://www.chrisdpratt.com/2008/09/...ons-itunes-library-installed-errors-occurred/

    http://discussions.apple.com/thread.jspa?messageID=7933758

    1. Delete the app from both iPhone and iTunes.
    2. Sync
    3. Download the app again. If you have paid for it, you will not have to pay again, even though it appears that you are going to have to.
    4. Go to the iPhone Applications tab and make sure "sync all applications" is checked. (There seems to be a bug which changes this to "check selected applications").
    5. Sync again.


    Bot didn't work for me.. Getting restless now.
     
  4. gray67 macrumors member

    gray67

    Joined:
    Aug 6, 2008
    #4
    This continues to be an issue post 2.1 update. Apparently Apple doesn't consider this a high priority bug.

    Be warned (just reinforcing again) - any apps that store data on your iPhone will most likely LOSE this data after you apply the workaround. I've had to use this workaround many times since 2.0.2, and I've stopped buying programs that store data locally because of it. I have one app that I'm REALLY hoping doesn't release an update before they fix this because I don't want to re-enter all the data.
     
  5. Henk van Ess macrumors newbie

    Joined:
    Aug 20, 2008
    Location:
    Amsterdam
    #5
    @gray: good for you that you have a work around! I don't. If I use the method of deleting all apps from iTunes and iPhone and then sync, I'm having a Groundhog Day all over again. After resyncing I download an app again, sync it, and then get the error again. The other way around: after I deleted all apps on iPhone and iTunes, disable syncing apps in iTunes, buy the same app again through the iPhone, download it since I own it, I get the error that I can't use the app yet, but I should sync it with iTunes first. If I do that, I get the Error 0xE8000002E error again.

    This is frustrating. I had six apps which I used very often. Basically, I can't install any app anymore although I paid for 10 of them. Any suggestions?
     
  6. gray67 macrumors member

    gray67

    Joined:
    Aug 6, 2008
    #6
    This is what I wound up doing. I can't find the direct link to the site that had the instructions, so I'm recalling by memory.

    Plug in iPhone.

    While it's plugged in, hold down the power and home keys for at least 6 seconds. This will cause iTunes to detect an iPhone in restore mode.

    Release the power button after six seconds (and after iTunes has detected restore mode) but keep the home button depressed for 10 seconds. iTunes will then walk you through a firmware restore. This resets your firmware to 2.1 (or whatever the most recent version of the firmware is that you have). This takes about 5-10 minutes.

    Once your iPhone is restored to its empty state, set up the iPhone as a new phone, not as a restore. This will cause iTunes to reinstall all the apps you have downloaded (and paid for) onto the iPhone. You will lose all your settings, data, and music/vids/podcasts on the iPhone. All of those can be re-synced. You will not have to reset your phone number or anything else.

    This is a painful process, especially if you have a lot of apps that store data on the iPhone, so I don't recommend it for everyone. Also, after I did it, I started getting a different error every time I sync (a dataclass initialization error of some type that annoys me but doesn't seem to impact the syncing itself).

    It turned out that I had an app update to apply so I didn't download the update until after I'd gone through the process above. After I got everything set up, I downloaded the app update and applied it successfully without getting the 0xE800002E error.

    If my directions are unclear, google the error code and you should be able to find the web site I mention above.

    Good luck. Hopefully Apple fixes this stupid error in its next update. Doubtful, but I hold out hope.
     
  7. Henk van Ess macrumors newbie

    Joined:
    Aug 20, 2008
    Location:
    Amsterdam
    #7
    @gray: fantastic, that did the job. Without even any strange errors, as you had. Still wondering: what causes this? Can it be replicated? Is there something I shouldn't do (f.e. updating Apps only through iTunes, or only through iPhone) to avoid a new firmware restore?
     
  8. gray67 macrumors member

    gray67

    Joined:
    Aug 6, 2008
    #8
    I am no longer getting that strange error - it went away after I exited iTunes and rebooted my PC.

    No idea what caused the issue in the first place, though there are some intertubes talk about DRM pointers being incorrect between firmware versions?
     
  9. Neebee macrumors 6502a

    #9
    I get this error ALL the time when I attempt to update an app. I also get an error message when updating through my iPhone via WIFI as well. The iPhone error itself says the app will update once connected to my PC.

    I am not about to uninstall the up (delete it) because I have settings saved and clips as well. I wont do a system restore either. It's retarded.
     
  10. firewood macrumors 604

    Joined:
    Jul 29, 2003
    Location:
    Silicon Valley
    #10
    Try deauthorizing, quiting, restarting and reauthorizing iTunes.

    .
     
  11. Neebee macrumors 6502a

    #11
    Nope doesn't work. Maybe it'll be fixed with this 2.2 update but I'm not holding my breath.
     

Share This Page