Error 1 operation not permitted, terminal not working

Discussion in 'macOS' started by SuperHero87, May 15, 2014.

  1. SuperHero87 macrumors newbie

    Joined:
    May 15, 2014
    #1
    Hi team, I'm trying to Unzip .gz file but the Error message of " Error 1 operation not permitted" is shown.

    I tried using the terminal to unzip the file but couldn't, below is the error message:

    *****MacBook-Pro:~ ****$ unzip /Users/*****/Documents/gcc-4.9-bin.tar.gz
    Archive: /Users/******/Documents/gcc-4.9-bin.tar.gz
    End-of-central-directory signature not found. Either this file is not
    a zipfile, or it constitutes one disk of a multi-part archive. In the
    latter case the central directory and zipfile comment will be found on
    the last disk(s) of this archive.
    unzip: cannot find zipfile directory in one of /Users/*****/Documents/gcc-4.9-bin.tar.gz or
    /Users/****/Documents/gcc-4.9-bin.tar.gz.zip, and cannot find /Users/******/Documents/gcc-4.9-bin.tar.gz.ZIP, period.
    ******-MacBook-Pro:~ ******$


    Kindly Help me Urgently.
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    From what I can see, it may be a corrupted zip or an archive created that the terminal commend is incapable of handling. Try using 7-zip its very robust and if that can't do it, I'm not sure any utility will be able too.
     
  3. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #3
    In Terminal, try the command gunzip, instead of the command unzip. Post its output.
     
  4. selda macrumors newbie

    Joined:
    May 19, 2014
    #4
    I have the same problem...
    Got the same error massage when unzip through Terminal

    Tried gunzip and got the next massage:
    gzip: (file path).zip: unknown suffix -- ignored
     
  5. mfram macrumors 65816

    Joined:
    Jan 23, 2010
    Location:
    San Diego, CA USA
    #5
    For the O.P., what is the name of the file? It ends in .tar.gz? If so, that can be unpacked by the 'tar' command in the shell directly.

    To list the contents:

    Code:
    tar tvf gcc-4.9-bin.tar.gz
    To unpack the contents:

    Code:
    tar xvf gcc-4.9-bin.tar.gz
     

Share This Page