Error 1002 While Restoring

Discussion in 'iPhone Tips, Help and Troubleshooting' started by waterskier2007, Jun 9, 2009.

  1. waterskier2007 macrumors 68000

    waterskier2007

    Joined:
    Jun 19, 2007
    Location:
    White Lake, MI
    #1
    If anyone could lend some knowledge that would be great. My iPhone went into recovery mode for some reason the other day. I plugged it into iTunes to restore, and after it downloaded the update for 2.2.1 (because i recently got a new computer) it started the restore no problem, did the software update, then updated the firmware. The progress bar on my phone filled but then my iTunes just kept saying 'Restoring iPhone firmware...'. After probably 30 minutes it told me 'The restore could not be completed (Error 1002)'. I have tried to restore probably 10 times, and I even reinstalled iTunes and trashed the mobiledevice files that the apple website recommends.

    Any help would be appreciated
    Thanks
     
  2. lovlykayla macrumors newbie

    Joined:
    Sep 27, 2009
    #2
    I had the same problem as you until i tried this:
    1. Download Quickpwn from http://www.iphonedownloadblog.com/iphone-downloads/
    1. Restore your iphone and get 1002 error
    2. Press Ok
    3. Open Quickpwn. Once opened a popup should come up explaining you need to restart your iphone. Follow these instructions and press ok (Do nothing else in quickpwn)
    4. Once you've restarted, exit quickpwn and open itunes.
    5. Now your iphone should boot normally

    I hope this works, it worked for me
     

Share This Page