Error 1004 ??

Discussion in 'iPhone' started by jimmythehill, Oct 25, 2011.

  1. jimmythehill macrumors member

    Joined:
    May 31, 2010
    #1
    Opened App Store on my iPhone 3GS (JB 4.3.4) yesterday and two apps needed updating. As usual, selected "update all" and entered my password for iTunes account.

    The phone left the App store as normal and went to the homescreen to begin the update. The app began to update but then stopped and error 1004 dialogue box appeared (see below)

    This seems to be happening whenever I try to either update or download any app.

    I have reset all the cache, history and cookies from settings, turned phone off the back on again (4.3.4 is tethered jailbrake and I've used RedsnOw to reboot the phone). I have logged out of iTunes and logged back in without success.

    Anyone help?

    IMG_1283.PNG
     
  2. wratran macrumors regular

    Joined:
    Nov 22, 2010
    #2
    I have the same issue on 3GS 4.3.3 jb
    Try resetting, rebooting, login logout from AppStore....nothing work
     
  3. jimmythehill thread starter macrumors member

    Joined:
    May 31, 2010
    #3
    Not sure if you're instructing me to reboot, log in / out or if you're stating that is what you have tried.
    I have tried all that without success...pffft!

    Have apple changed something with the app store that conflicts with JBs?
     
  4. wratran macrumors regular

    Joined:
    Nov 22, 2010
    #4
    I try it all..nothing work.
    I'm not on tethered jb....
     
  5. jimmythehill thread starter macrumors member

    Joined:
    May 31, 2010
    #5
    Do you have User Agent Faker tweak?
    I checked Cydia and updated that... App Store is working fine now...
    Whether UAF was the actual problem, I'm not sure.
     
  6. bjpembo macrumors newbie

    Joined:
    Oct 25, 2011
    #6
    User Agent Faker seemed to be the key for me. I've been searching the net for 2 days trying to figure this out. All of the solutions I came across from changing the 12/24 hour clock, changing the auto time update to manual, clearing the cache cookies and history for safari as well as doing a reset of the phone all failed to do anything.

    After seeing the suggestion of UAF, I realized there was an update in cydia a couple of days ago so I though I'd try removing it and after restarting my phone, it was fixed. I was immediately able to download an app from the app store.
     
  7. Gathomblipoob macrumors 68040

    Gathomblipoob

    Joined:
    Mar 18, 2009
    #7
    There's now another update for UA Faker that fixes the App Store issue.
     

Share This Page