Error 102 (net::ERR_CONNECTION_REFUSED): Unknown error - I've tried everything.

Discussion in 'Mac Apps and Mac App Store' started by mhunterak, Feb 18, 2010.

  1. mhunterak macrumors newbie

    Feb 18, 2010
    Long time reader at MacRumors, first time posting.
    Here's the rundown of the issue I'm having:

    About a week ago, I switched from DSL to a Cable Modem (10x faster, 50% cheaper... hurray, right?) and two days later my computer stopped connecting to the internet, or so I thought. It seemed I was unable to connect to google, or anything google-related, i.e. picasa, youtube, google reader, gmail.
    My website uses google HTML snippets, which do not load (

    • Using a 2006 15" MBP with snow leopard 10.6
    • Most sites work fine.
    • Getting the same error on
    Safari 4 (Safari can’t connect to the server)
    Firefox 3.6 (Unable to connect)
    and Google Chrome (Error 102 (net::ERR_CONNECTION_REFUSED): Unknown error)
    • No Google sites load.
    • Yahoo opens maybe 50% of the time.
    • Other computers on the network load google just fine.

    Troubleshooting steps I've tried:
    • rebooting my modem and router (duh)
    • resetting my wireless router
    • resetting my airport settings
    • clearing my browser settings (all of them)
    • flushing the dns cache with terminal command
    dscacheutil -flushcache

    I've tried everything short of a complete system restore. What am I missing guys?!

    Thank you,
  2. mhunterak thread starter macrumors newbie

    Feb 18, 2010
    I had to open it on my iPhone, thanks for posting a link to the website I'm asking for help about. You know, because my computer isn't connecting to it. I've already tried the solutions they offer.
  3. GGJstudios macrumors Westmere


    May 16, 2008
    Text of the site:

  4. bmcgonag macrumors 65816


    Mar 20, 2007
    have you checked that your firewall is not blocking google for some unknown reason?

    Have you installed any new software since your switch (particularly anti-virus, or "cracked" software)? If so, then uninstall, and immediately run a virus and malware scan and clean. then uninstall the anti-virus software and try again.

    You said all computers on the network can get to google fine. Are they all running through the Airport and the router, or just the mac?
  5. jasrneff macrumors newbie

    Mar 24, 2011
    Same problem

    I'm having the same problem. No solutions for macs are out there. Did anyone ever get an answer to this? It's killing me not being able to use google. Tried every browser. It has to be in the network settings.
  6. hererightnow macrumors newbie

    Mar 24, 2011
    I am also having this problem as of yesterday afternoon on both my home internet connection and work
  7. _bgb macrumors member

    Mar 9, 2011
    this is driving me crazy..happened yesterday, network provider even had his buddies over to see my problem as it was so odd..

    apple booked me in with a 'Genius'..see what they have to say, all happened after the latest update..
  8. TreoRenegade macrumors regular

    Aug 7, 2008
    May be a long shot, but have you tried switching the DNS servers to Google-- and I have Time Warner, and sometimes TW's DNS stuff just gets inexplicably shot to heck. When I go into the router settings and change from the TW's DNS servers to Google's, joy returns. Worth a shot.
  9. RetroP macrumors newbie

    Mar 24, 2011
    Same problem here. Macbook with OS X 10.6.6. No change in setup or software, came home from work yesterday afternoon and now google (all sites), youtube, yahoo, and many others get ERROR_102. Same in all browsers. Others connected to the same wifi router can still connect as normal. Whats going on? Apple? Google?
  10. hererightnow macrumors newbie

    Mar 24, 2011
    Still no luck for me. No one in my house or at my office has this issue (two different service providers also), but I think it is interesting this happened to everyone at the same time.
  11. RetroP macrumors newbie

    Mar 24, 2011
    Still no luck for me here either.
    Still able to access various other websites, so connection is intact.
    - Firewall is disabled.
    - Parental controls disabled.
    Tried clearing the DNS cache with:
    dscacheutil -flushcache
    but this made no difference.

    I DO get a response if I ping, but traceroute does not work. Results below:

    $ ping [url][/url]
    PING [url][/url] ( 56 data bytes
    64 bytes from icmp_seq=0 ttl=52 time=368.409 ms
    64 bytes from icmp_seq=1 ttl=53 time=338.086 ms
    64 bytes from icmp_seq=2 ttl=53 time=319.346 ms
    64 bytes from icmp_seq=3 ttl=53 time=328.449 ms
    $ traceroute [url][/url]
    traceroute: Warning: [url][/url] has multiple addresses; using
    traceroute to [url][/url] (, 64 hops max, 52 byte packets
    traceroute: sendto: No route to host
     1 traceroute: wrote [url][/url] 52 chars, ret=-1

    This could well be the most annoying computer problem I've had in years...hope someone can find a solution soon.

    Are there any other steps that I have not tried to clear the DNS cache etc?
  12. pdxber macrumors newbie

    Mar 25, 2011
    I had the same issue - started two days ago. Drove me crazy and tried everything.

    Fixed it today by disabling an IP blocker that I installed a year ago called PeerGuardian.

    Hope that helps!
  13. hererightnow macrumors newbie

    Mar 24, 2011
    It was PeerGuardian for me too! Thank you, pdxber!
  14. RetroP macrumors newbie

    Mar 24, 2011
    Great to hear some of you have had success by disabling PeerGuardian. I have managed to fix the problem by deleting the contents of the following folders:


    Restart your computer and voila!

    I found this and other suggestions in this thread on Apple Discussions.

    Hope you all manage to get Google back :)
  15. pulizziva macrumors newbie

    Apr 11, 2011
    Error 102

    Hello, MacRumors

    I have been a reader of the forums, however I decided to join MacRumors because of this issue. Recently, my browsers became unable to view any google affiliated websites. Google chrome rendered Error 102 like all of you have written. I have fixed my problem last night and wanted to share my solution.

    I am an Ableton Live user and Max/MSP programmer. I demand a lot out of my computers memory and usage. Pretty much each week, I optimize my computer, erase my cache, and maintain my computer for efficient live performances.

    The software I use to perform this is Snow Leopard Cache Cleaner. My problem developed after I had interrupted a optimization of my computer.
    I didn't put two and two together, shortly after this, I could not view google affiliated websites.

    I read this forum, I disabled PeerGuardian, deleted my cache like the poster above suggested, then I repaired my permissions, optimized my memory, and cleaned my cache. When, I started my computer this morning, boom, I was back into my gmail and left to read hundreds of emails I was restricted from for the weekend. I haven't enable PG yet, I will post later if PG is an issue. I hope this helps and I hope google becomes more aware of this problem because I seems to be sourced around Chrome and is both Mac and PC related
  16. jtalky macrumors newbie

    May 21, 2012
    Lion Restore - doesn't work

    This fixed all of my problems - deleted corrupt PeerGuardian and all is well again.

  17. bleedragon23 macrumors newbie

    Jul 30, 2015

    I know this is an old thread, but I recently went through this same problem recently. I can confirm that removing all evidence of Peer Guardian version v.180b2 and it agents will help. Not until I cleared all cache in the libraries, did it truly restore ALL of my connectivity. You will need to make your User library visible if it is hidden. It was key to clear that User Library cache.

    Make Library unhidden:
    * From the OS X Finder, open a new window and go to the users Home folder (hit Command+Shift+H to jump to Home instantly)
    * Pull down the “View” menu and select “Show View Options” (or hit Command+J if you like keyboard shortcuts)
    * Check the box for “Show Library Folder” then close the View Options panel
    * Navigate in the users home folder to see the newly visible “Library” directory

Share This Page