error 1603 while updating to 3.1.1

Discussion in 'iPod touch' started by hoobastank, Sep 9, 2009.

  1. hoobastank macrumors newbie

    Joined:
    Aug 27, 2009
    #1
    iTunes destroyed my iPod touch today. I finally finished downloading the software update. Then when it began to update, there was an error. iTunes detected it as an iPod in recovery mode, and began to restore it. Didn't work either. No my iPod is a brick. I'm going to try to restore it a few more times, or I'll have to go to the Genius Bar. Now, my Touch has no OS, and just shows the apple icon with an empty progress bar.
     
  2. angar macrumors newbie

    Joined:
    Aug 8, 2009
    #2
    same thing happened to me, but while updating to 3.0... someone else told me to take to an Apple store to exchange it... but here is how i fixed it:

    I downloaded Itunes in another computer, this way the 3.0 update will not be stored in this computer... so after plugging in my ipod, Itunes detected that it needed to be restored and asked me to download the lastet OS version... in this case will be the 2.2.1 (which is the last free version, because as we know, you have to pay for 3.0 and 3.1)... after downloading and installing the old version, my ipod worked perfectly again....

    Hope this helps you!

    I still haven't updated my ipod... I want to, but I'm still afraid that the same thing will happen with 3.1, I think I will take to an apple store before I do it...
     

Share This Page