Error 2001 after Jailbreaking iPod Touch 1G

Discussion in 'iPod touch Hacks' started by Yondaime111, Apr 29, 2009.

  1. Yondaime111 macrumors newbie

    Yondaime111

    Joined:
    Jan 26, 2009
    #1
    I ran QuickPWN. My iPod went through the process where it installs all the Jailbreak stuff. It rebooted, and kept re-rebooting. iTunes would open up and freeze. I force quit it and reopened it, and it would freeze again. After about an hour of it, I put my iPod into DFU mode. iTunes opened up and had a little window that said "Waiting for iPod" and had a little progress bar. After that it said it couldn't connect (error 2001) I quit iTunes and reopened it, but it still came up with error 2001, and again several times after that. Once, a little window came up saying my iPod had diagnostic information that could help apple. I clicked "show details" button and copied the information, and did not send to apple. Could somebody please help me? I pasted the information below:


    Important info:
    iPod Touch 1G
    firmware 2.2.1
    jailbroken on 10.5.0 partition
    tried to enter DFU mode on 10.5.6 partition



    Code:
    2009-04-29 20:41:40.000 iTunes[269:20b]: restore library built Feb  3 2009 14:37:06
    2009-04-29 20:41:40.000 iTunes[269:20b]: iTunes: iTunes 8.1.1
    2009-04-29 20:41:40.000 iTunes[269:20b]: iTunes: Software payload version: 5G77
    2009-04-29 20:41:40.000 iTunes[269:ed0f]: iTunes: Specifying UOI boot image
    2009-04-29 20:41:46.000 iTunes[269:ed0f]: error setting configuration descriptor: 0xe0004051
    2009-04-29 20:41:46.000 iTunes[269:ed0f]: unhandled error 0xe0004051 returned as 2001
    2009-04-29 20:41:46.000 iTunes[269:ed0f]: unable to open DFU device: 2001
    2009-04-29 20:41:55.000 iTunes[269:20b]: iTunes: Restore error 2001
     
  2. supess macrumors newbie

    Joined:
    May 6, 2009
    #2
    Solution?

    I am having the same issue. Were you able to figure out a solution?
    I read somewhere that iTunes 8.1.1 prevents the iphone from going into DFU mode and that could be causing the 2001 error.

    Please let me know.

    Thanks
     

Share This Page