Error -34

Discussion in 'iOS 5 and earlier' started by sprocket003, Oct 12, 2011.

  1. sprocket003, Oct 12, 2011
    Last edited: Oct 12, 2011

    sprocket003 macrumors newbie

    Jun 25, 2007
    Because I had those issues I ended up option-clicking on "Restore" and used the .ipsw file for the new iOS 5.0. It worked and all, rebooted the iPhone, but then when after it was restoring my iPhone Apps from the backup I received error message -34. Anyone know why?

    Update: Turns out it did restore fine and I had to do some setup prompts on the iPhone itself. Now its working.
  2. Draft, Oct 18, 2011
    Last edited: Oct 19, 2011

    Draft macrumors 6502

    Jun 18, 2002
    Chicago, IL
    I'm having this issue as well. I've tried wiping and restoring, but every time I get to the restoring step, I get the -34 error. This error is preventing the syncing of music to my iPhone.

    This same problem seems to be all over the Apple Support Community forums:

    In reading through those threads, it looks like a problem where the 'Convert higher bitrate songs to 128 kbps AAC' isn't persisting in the backup from iOS4 to iOS5. Does anyone know how to address this while keeping my iPhone data in tact? Possibly edit the backup file? If not, the only option I can see that ensures I don't lose my current iPhone state is to backup my phone to iCloud, wipe, then restore from iCloud. This could take a while as my picture library is 3.3 GB, so I'm dreading this. Are there any other options out there?

    Thanks in advance.



    I tried the 'delete backup' button again and that fixed it. I just had to re-select my music, but all other data was sync'd. Not sure if I glossed over this the first time through those threads or if it didn't work, but I thought I had done this originally. Of note, you should take a backup your iOS device backups before continuing with this, just in case..

Share This Page