(Error - 36)some data could not be read or written..

Discussion in 'iMac' started by glen4cindy, Jan 5, 2009.

  1. glen4cindy macrumors newbie

    Sep 22, 2005
    I just changed security programs on my PC and am now having trouble sharing my hard drive with my Mac's, an eMac and a PPC MacMini. In the past, I have had no problems connecting using smb://

    Now, I cannot connect unless I check on the PC ALLOW ALL TRAFFIC. I can then uncheck allow all traffic and continue to be connected and read and write files to the shard drive.

    I tried opening TCP and UDP on ports 139 and 445, but, this still does not help.

    The security suite my ISP uses is from F-Secure.

    I'm thinking that this is going to involve a rule of some sort, but, when I use the logging function on the PC, each time I try to Connect to Server on the Mac, it originates from a different port on the Mac to the PC. It is always trying to connect to 445 on the PC.

    I also get a message popup on the PC from the security suite saying that the traffic has been ALLOWED. That is the part that is stumping me. In every case, it says it has allowed the traffic, but, the Mac reports that "some data could not be read or written."

    This was not a problem until I installed the security suite. I have the sharing set up to allow network users to change my files, so it cannot be that aspect of things.

    Any help would be appreciated.

    Attached Files:

  2. UltraNEO* macrumors 601


    Jun 16, 2007
    Find the IP address your Mac is using, then add it to the ALLOW section of your firewall.

    When I'm using my PC, I don't install an additional software based firewall, cause most semi-decent routers have one built-in.
  3. glen4cindy thread starter macrumors newbie

    Sep 22, 2005
    Well, I have the security suite for the virus protection, spam filter, popup blocker, etc. and it just comes with the firewall.

    I added the following to the ALLOW and still cannot connect even though I get a message saying that the traffic has been allowed: - <--- My Airport static IP <--- My ethernet static IP

    Still no dice.

    I guess I will just have to ALLOW ALL TRAFFIC, connect to the share, and then make it filter traffic again.

    I appreciate the suggestions, but, this one has me stumped! I wonder if it is a timing thing with the Mac giving up. Thing is, it keeps trying to connect because the firewall keeps receiving different packets over and over again even after I have chose cancel after the connection failed.

    I'm the kind of tech that likes to figure out what the problem is, no matter how simple or complex, when I have a problem like this. I have not called Charter tech support because they only support ONE computer attached to the MODEM and do not support home networking unless you SUBSCRIBE to Charter Home Networking, which I am NOT going to do since I can do it myself! I'd just like to find a solution to this problem, one that is seamless, that does not require me to turn things off just to connect. If it matters, I'm running Tomato on a Linksys WRT54G.

    Thanks for the help, and any more is greatly appreciated.
  4. glen4cindy thread starter macrumors newbie

    Sep 22, 2005
    UPDATE - This problem is SOLVED

    After doing some more research and reading, I found some information.

    After configuring the firewall to ALLOW ports 137, 138, and 139,

    I now can connect without ANY issues.


Share This Page