error code 1004

Discussion in 'iPhone' started by bravens52, Jul 15, 2010.

  1. bravens52 macrumors regular

    Joined:
    Jul 16, 2009
    #1
    hey guys im trying to update to 4.0.1 but when it is restoring the firmware it says error 1004 and it has basically bricked my phone..how can i update and get my "Phone" back ( i use the term phone loosely when it comes to apple)
     
  2. bravens52 thread starter macrumors regular

    Joined:
    Jul 16, 2009
  3. caciquez macrumors newbie

    Joined:
    Nov 22, 2008
    Location:
    San Juan, Puerto Rico
    #3
    Help please

    I have the same problem, get everything right but I can not install 4.1 on my iphone 4G throws me error 1004 because ... Help please
     
  4. psudude macrumors newbie

    Joined:
    Aug 2, 2008
  5. iPadThai macrumors 6502a

    Joined:
    Apr 25, 2010
    #5
    You can check if you modified your /etc/hosts file. If so, comment out the gs.apple.com server line with a # symbol.

    It will work. If it doesn't, then you may have another problem. I encountered this when I installed iOS 4.1 - but forgot to comment out the gs.apple.com host.
     
  6. bribri10 macrumors newbie

    Joined:
    Jul 16, 2010
    #6
    Unbricked after error code 1004

    After 3 failed attempts with "error code 1004" and thinking my iPhone 4 was bricked, I finally got it to work.

    I think the problem might have been a corrupted ipsw file. This all happened on my Macbook Pro - an error loop of "connect to iTunes" on the iPhone 4, and then an "error message 1004" on the iTunes of my Macbook Pro after trying to restore.

    After switching to an Windows XP netbook, everything worked fine. Then I simply restored all the data from my backup on my Macbook Pro.

    My guess is the ipsw file was corrupted on the Macbook Pro. Perhaps if I had deleted it, causing iTunes to redownload, things would have worked.

    I was just ecstatic that the netbook made things right. Good luck to you!
     
  7. fubartoo macrumors newbie

    Joined:
    Sep 8, 2010
    #7
    Thanks for the hosts file solution - I forgot I edited it and was getting the 1004 error. Seeing how I go now...
     
  8. ljx718 macrumors 6502

    Joined:
    Dec 13, 2008
    #8
    yes, i would have many problems with my macbook pro, but was fine on bootcamp. weird
     
  9. Martinsalas310 macrumors regular

    Joined:
    May 13, 2010
    Location:
    Nampa, idaho
    #9
    if u use recboot or tintyumbrella just to kick the iphone out of recovery should work right?...try and reply back to give us more info.
     
  10. parker770 macrumors member

    Joined:
    Apr 5, 2010
    #10
    This should work. I was getting the same error when I downgraded to 4.0.1 after trying the 4.1GM. I decided that I wanted to keep my JB, so I had to modify the hosts file to contact Saurik's server since Apple's server didn't want to allow the downgrade.

    I just used tinyumbrella to kick it out of recovery mode and it worked beautifully.
     

Share This Page