Error code 1013 when updating to iOS 4.2.1

Discussion in 'iPhone' started by bbhegedus, Nov 22, 2010.

  1. bbhegedus macrumors regular

    bbhegedus

    Joined:
    Aug 22, 2010
    #1
    ive spent almost two hours doing anything i can to this damn iphone. i have the iphone 4. when i first installed 4.2.1 it crashed halfway through the process and made me enter recovery mode. ive been stuck in recovery mode for hours. no hope. keep getting error code 1013 towards the end of the recovery process. ive tried forcing it out of recovery mode with tinyumbrella but no hope. any one else with this issue!? HELPPP
     
  2. georgi0 macrumors regular

    georgi0

    Joined:
    Aug 21, 2006
    Location:
    Cyberspace
    #2
    i have similar issues

    how long does it take to make a clean restore? it's stuck at around 60% of the bar update on the iphone and just before the end on my itunes update bar..

    i also tried restoring to 4.1 with the same issues...

    i cant tell if I am stuck or the update is going on as it takes forever to change or move the bars just a bit...

    i have to work also in a couple of hours..
     
  3. chuckcastle macrumors newbie

    Joined:
    Nov 22, 2010
    #3
    Find the solution here:

    http://discussions.apple.com/message.jspa?messageID=12630974#12630974

    1. Go to your "Applications" folder
    2. Go to your "Utilities" folder
    3. Launch "Terminal"
    4. Type "sudo nano /etc/hosts" (without quotes) and hit return
    5. Enter your password
    6. Use the down arrow key to find the "gs.apple.com" entries. Once the cursor is in front, make sure you comment out the line(s) by entering "#" (no quotes) in front of the text
    7. Save the file by pressing CONTROL+O on the keyboard
    8. Exit the nano editor by pressing CONTROL+X on the keyboard
    9. Restore your iDevice
     
  4. intrepid00 macrumors 6502

    Joined:
    Sep 28, 2008
    #4
    For windows users

    C:\windows\system32\drivers\etc\

    In there is the HOSTS file. Copy it to your desktop, edit with notepad and copy it back to the folder you found it.

    The entry is probably made by tinyumbrela.
     
  5. peteisanidiot macrumors regular

    Joined:
    Jun 23, 2010
    #5
    I had a similar experience using a non-OEM data cable.
     
  6. saintsbabylove, Nov 22, 2010
    Last edited: Nov 22, 2010

    saintsbabylove macrumors member

    saintsbabylove

    Joined:
    Sep 6, 2010
    #6
    Found it. now what am I suppose to be editing in the notepad?
     
  7. orpheus1120 macrumors 65816

    orpheus1120

    Joined:
    Jan 23, 2008
    Location:
    Malaysia
    #7
    +1 true that.
     
  8. twostep665 macrumors member

    Joined:
    Aug 4, 2010
    #8
    we shouldnt have to edit any type of file. this is an official release the error is happening on.
     
  9. tadad1 macrumors 6502a

    tadad1

    Joined:
    Oct 20, 2008
    #9

    If there is an entry "74.208.10.249 gs.apple.com" delete it or put a # in front of it, save then reboot you PC.
     
  10. saintsbabylove macrumors member

    saintsbabylove

    Joined:
    Sep 6, 2010
    #10
    Thank You! All I did was delete it and then restored my phone and it worked! Thanks again!
     
  11. benjaminwood macrumors newbie

    Joined:
    Nov 23, 2010
    #11
    I'm on a iPhone 4. I've read that others have successfully used tiny umbrella to save their baseband on the 4.1.2 update today. However, I'm getting this same 1013 error and can't kick it out of recovery mode. Obviously, undoing the gs.apple.com line will allow itunes to update my baseband. Are there any other tricks out there for people in my position? Thanks in advance! :D
     
  12. kuberan macrumors newbie

    Joined:
    Nov 23, 2010
    #12
  13. benjaminwood macrumors newbie

    Joined:
    Nov 23, 2010
    #13
    Thanks for the reply! However, I don't think this will do it for me (or others seeking what I'm seeking). The "erroneous" gs.apple.com host entry isn't actually an error at all. It's part of the way Tiny Umbrella works to block itunes from "talking" with apple. It instead loops all traffic back to the localhost (In this case, Tiny Umbrella). If I was to delete or comment out the gs.apple.com line in my host file- Tiny Umbrella would just add it again when I start up the TSS server.

    I need Tiny Umbrella to work so that itunes won't update my iPhone 4's baseband. Also note that what I'm speaking of is only possible on the iPhone 4.

    The weird part is that I have heard of success from a couple people. Only problem is I can't get anybody to reply to me! Anybody that has done this successfully please help us out! :eek:
     
  14. Maziar macrumors 6502

    Joined:
    May 22, 2010
    #14
    Try recboot. I had the same error when updating my phone and recboot fixed it for me.
     
  15. yegon macrumors 68020

    Joined:
    Oct 20, 2007
    #15
    I had this problem, but thankfully chuckcastles intstructions solved it. Cheers.
     

Share This Page