Error Code -36 in Finder

Discussion in 'macOS' started by MoodyM, Jun 17, 2010.

  1. MoodyM macrumors 6502a


    Aug 14, 2008
    Ok, first of all the following issue is NOT fixed by doing dot_clean <path name> in Terminal, as suggested by Googling. I've had that issue before with FAT memory sticks, and it works, but it does NOT solve the following issue (that issue was solved in 10.6.3 anyway, and my problem below is happening in 10.6.3 and 10.6.4).

    Basically I have 17 mkv video files in my downloads folder, all 4.7GB each. I tried to move them to my external HD (connected to another Mac) over the network, as I always do when putting media on my Mac Mini, and it failed on the first one at 2.08GB with Error Code -36, full error:

    "The Finder can’t complete the operation because some data in “filename.mkv” can’t be read or written.
    (Error code -36)"

    The same thing happened with files 4 and 9 (not at 2.08GB, but at some other point), but 2, 3, etc and the rest all moved just fine.

    I tried copying them instead of moving them, exact same problem.

    I tried using Terminal to copy then using the cp command, same problem (wasn't Error Code -36, but "Input/Output Error", but according to Google it's the same thing)

    I tried putting them into a sub folder within Downloads and using cp -r to copy the whole folder, same problem.

    I tried connecting the external USB drive (it's Mac OS Journaled by the way) directly to my MacBook Pro and copying them, same problem.

    I can't even copy/paste them where they are (i.e. if I just select the first one and do Cmd-C, Cmd-V to make a copy in the source folder), I get the exact same problem.

    I even booted into Windows 7 through Parallels and tried using Windows to copy them to the external HD, same problem (again, not Error Code -36, but some generic I/O error).

    What I CAN seem to be able to do without error is move them around my MacBook Pro hard drive (not copy, but move).

    Any ideas?

  2. jordienla macrumors newbie

    Jun 18, 2010
    leopard 10.6.4 error code 36

    Yeah, similar issue, I have an imac 27" i5, that looks good but it is useless on copying files or back up to external drives, how sad is that!.
    I first thought it was my drive, I did try with different ones, all of them are formatted as Mac OS extended, then I thought my cables or something else, I replaced them. I couldn't copy files from one external drive to another, either copy or add photos to my lightroom catalogs that live on one external drive, neither back up with time machine, the drives stop working after a while, (files could not be read or written error code -36), I called apple, My computer it is 5 moths old so no telephone support after 3 months, they tell me to get apple care, I respond that apple products have one year warranty, I will get that on the 11th month, they finally sent me an useless email about how to reset my SMC. HOW BAD IS THAT!, APPLE LAME!,
    Lucky me I have a MBP running tiger, I mounted the drives and so far I have been able to copy my first 166g of photos into another drive for back up purposes. Now I now it is not the drive, either the files, I just started copying my second batch of 100g no errors so far.
    The worst thing about apple's lame support, it is that they don't recognize when something is wrong. It is most likely a leopard update issue. I do need my computer everyday, so I do not want to go 50 miles away for a service place, and have it sitting there for a couple of weeks, I guess I'll wait for another update. but I have an expensive computer sitting with very limited capabilities.
    I am very disappointed.:mad:
  3. Hal Itosis macrumors 6502a

    Hal Itosis

    Feb 20, 2010
    It's either directory damage or (more likely) the disk itself is physically damaged. The first possibility could be repaired by Disk Utility and/or DiskWarrior [and neither was mentioned in your post there.] If the latter, then you're probably SOL as far as those particular files go.

    The reason "moving on the same disk" works is that the file data is never actually moved... rather, directory entries are simply edited. The damage is likely to be where the files themselves are currently located on disk.

    EDIT: You can try using something more persistent than Finder to copy those items (such as ditto instead of cp, or a backup utility perhaps... but generally stuff which can't be read reliably can't be copied properly).
  4. arogge macrumors 65816


    Feb 15, 2002
    I am now having the same problem when trying to copy CompactFlash cards over USB to the computer. Seemingly at random, the file copy operation in Finder will stop and an error message appears:

    "The Finder can't complete the operation because some data in <Variable Filename> can't be read or written. (- Error code 36)"

    The USB card reader is then cut off, resulting in OS X complaining about how I didn't Eject the card properly. Gee, it sounds like I'm being scolded by Microsoft ScanDisk. Oddly enough, this only happens with my brand new Sandisk 16 GB UDMA card. This problem only started happening when I upgraded to the OS to 10.6.5. Older versions of the OS, including 10.6.3, did not have this problem.
  5. tahoeroscoe macrumors regular


    Apr 25, 2009
    I'm on 10.6.7 and also have this issue, TTT if anyone else has ideas
  6. Tomorrow macrumors 604


    Mar 2, 2008
    Always a day away
    I used to have this problem, and dot_clean did fix it - but you have to use the command recursively.

Share This Page