(error code -50) when trying to empty trash

Discussion in 'Mac Pro' started by Vanderdecken, Sep 17, 2017.

  1. Vanderdecken macrumors newbie

    Joined:
    Sep 17, 2017
    #1
    Hello,

    I'm having a problem getting some files emptied from my trash. The were some old art portfolio pc files from the 90s I dug out of some archives and copied. Now I can't trash them (the Mac files I copied were fine and I was able to delete them).

    I'm running a Mac Pro (early 2008) with El Capitan. I've done some research on the problem and have tried Trash It! and Cocktail's file removal utility to no avail (I also tried putting the files in different folders in the trash). I've also tried Terminal > sudo rm -ri ~/.Trash and get Invalid Argument when I try to remove the files. I've also tried restarting multiple times and Disk First Aid finds no problems.

    When I cycle through the trash messages some are The operation cannot be completed because an unexpected error occurred (error code -50), and other's are File Is In Use.

    Thanks in advance and assistance would be greatly appreciated!
     
  2. pat500000 Suspended

    pat500000

    Joined:
    Jun 3, 2015
  3. Vanderdecken thread starter macrumors newbie

    Joined:
    Sep 17, 2017
    #3
    Yeah, tell me about it lol. This was an intranet game I designed to run on Olin Chemicals internal intranet back in 1997. Now the PC files fouled up my trash.
     
  4. h9826790 macrumors G5

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #4
    How about just

    sudo rm -r

    But not

    sudo rm -ri
     

Share This Page

3 September 17, 2017