error code -50 with copying large avi files from mybooklive

Discussion in 'OS X Mavericks (10.9)' started by anis2002, Feb 20, 2014.

  1. anis2002 macrumors newbie

    Joined:
    Feb 20, 2014
    #1
    I recently purchased macbook pro with retina display. I manage to transfer all my data from Windows laptop to macbook pro with no issues. I also have mybooklive network device from there whatever i want to copy, i copied it with no problem. the files includes doc, excel, txt, iso etc with all kind of size from 1kb to 4GB and it's copied with no problems.

    Now when i try to copy an avi movie file of 700MB form mybooklive to macbook pro, it's copied with no problem. But when i try to copy an avi movie file over 2GB, i immediately got following error

    The operation can’t be completed because an unexpected error occurred (error code -50).

    This error is appearing when i am copying .avi files. Other larger files are copying without any issues.

    I also try to copy same file on my windows laptop from mybooklive and it's copied with no issues. Issue is coming only in macbook pro.

    Mybooklive is formatted on NTFS format but i am able to copy/paste everything. I am also using it for my timemachine backup of around 150GB and it was done with no issues. Only problem is when i am copying larger .avi files.

    Any help or suggestion.
     
  2. billyb2 macrumors newbie

    billyb2

    Joined:
    Oct 15, 2012
    Location:
    SoCal
    #2
    I cannot give you a specific solution since I am experiencing the same issue as you are. But it has something to do with SMB2 and the server you are connecting to. For example, here at work, I connect to multiple server types. Some connect fine, some do not.

    One of our servers I get the -50 error when I try to transfer files like you do. A temporary fix is to connect as cifs://servername and I can connect now. It is not ideal, but will work for now.

    So try:
    cifs://yourservername

    Let me know if that works for you. Because it is working for me until we can get everything working properly. :)
     
  3. anis2002 thread starter macrumors newbie

    Joined:
    Feb 20, 2014
    #3
    resolve

    hi billyb2

    thank you very much for your help. it's really work now...
     

Share This Page