error code 61

Discussion in 'Mac Basics and Help' started by pjfan281, Mar 21, 2009.

  1. pjfan281 macrumors newbie

    Joined:
    Nov 20, 2008
    #1
    i took the advice of people online and created a sparse image file as a way of password protecting folders on my hard drive. worked well for a while. these days, when i try to add or delete files from that sparse image, i get error 61 code. why can't i write/delete from that mounted image anymore?
     
  2. Jethryn Freyman macrumors 68020

    Jethryn Freyman

    Joined:
    Aug 9, 2007
    Location:
    Australia
    #2
    Have you modified the permissions, or locked the .sparseimage file?
     
  3. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #3
    According to this thread, that error is a bad master directory block. It's a possible sign that the drive where your spareimage is at is failing. Where is the sparseimage e.g., on your Mac or an external HD?

    You can attempt doing a verify and repair on the drive where it's at using Disk Utility, but no guarantees.
     
  4. pjfan281 thread starter macrumors newbie

    Joined:
    Nov 20, 2008
    #4
    the image is on an external hard drive, used for backups. i don't think i've ever messed with any of the permissions. when i created it, i gave it a password. i can still enter the password, which unlocks and mounts the image. from there i can open files and such, so i have read access. i just can't add to or delete from the image. somehow i lost those permissions. i attached a shot of the "get info" screen on the drive. i notice on the bottom now it says "you can only read" even though the option below it says "read/write". those buttons are grayed out and cant be clicked.

    i ran disk utility before and hit both verify disk and repair disk, both said to have went through without error.
     

    Attached Files:

    • mac.png
      mac.png
      File size:
      49.7 KB
      Views:
      54
  5. pjfan281 thread starter macrumors newbie

    Joined:
    Nov 20, 2008
    #5
    oh i figured it out. apparantly the image was locked. i noticed this when i did "get info" on the image itself before mounting it. unlocked and works fine now =)
     

Share This Page