Error: contact Apple for the 3.1.1 (1X234) device support package

Discussion in 'iOS Programming' started by Danneman101, Sep 30, 2009.

  1. Danneman101 macrumors 6502

    Joined:
    Aug 14, 2008
    #1
    I just tried viewing my ipod toch 2nd gen (both 3.0 and 3.1.1 updates) in the xcode's organizer, and for both versions got this error-message:

    "The Developer Disk Image could not be mounted.
    Xcode could not find an appropriate Developer Disk Image to mount on [MY] iPod. Please contact Apple for the 3.1.1 (1X234) device support package."

    Ive sent an email to apple, but considering they are notoriously tardy when replying its best to direct such inquiries to the community instead.

    Any ideas?

    ps. the exact nr after "3.1.1" is another, since Im guessing this has to do with the id of my device. If it has to do with the id of the actual support package, then Ill just let me know and Ill post it :)
     
  2. Troglodyte macrumors member

    Joined:
    Jul 2, 2009
    #2
    I think you need to download the latest version of Xcode/iPhone SDK.
     
  3. Danneman101 thread starter macrumors 6502

    Joined:
    Aug 14, 2008
    #3
    Oh...but I dont want to screw things up with my projects by upgrading xcode, since I got a good thing going with version 3.1. Is it possible to make a separate installation and thus having two versions of xcode on the same machine? (Im a bit new to how mac os works...)
     
  4. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #4
    Yes, it is, and the Xcode Read Me explains how this can be done.
     

Share This Page