Error: disk1s3: device is write locked

Discussion in 'Mac OS X Lion (10.7)' started by mnbbrown, Jun 11, 2011.

  1. mnbbrown macrumors newbie

    Joined:
    Jun 11, 2011
    #1
    Trying to remove the buggy kext from the Lion Install and after I attempt to mount the file system as r/w using mount -uw / i keep receiving the following error:

    disk1s3: device is write locked
    0 [Level 3] [ReadUID] [Facility com.apple.system.fs] [DevNode /dev/disk1s3] [MountPt /] [FSLogMsg 1293314605] [FSGLogMsgOrder Last]
    0 [Level 3] [ReadUID] [Facility com.apple.system.fs] [ErrTyp IO] [ErrNo 13] [IOType Write] ....

    What am I doing?

    Any help would be great..
    Cheers,
    Matthew
     
  2. Mr.Awesome macrumors newbie

    Joined:
    Feb 28, 2010
    #2
    I have exactly the same problem. Any help would be appreciated ...
     
  3. sudoash, Jun 12, 2011
    Last edited: Jun 12, 2011

    sudoash macrumors member

    Joined:
    Jun 12, 2011
    #3
    Likewise. Steps to reproduce:

    1. Load installer for SL
    2. Select secondary partition
    3. Reboots
    4. CMD+S into Installer partition
    5. Run "/sbin/fsck -fy" [edit: added this step]
    6. Run "/sbin/mount -uw /"
     
  4. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #4
    And you ran fsck before you mounted it?
    Just reading some dev forum posts, they mentioned that step might be needed.
     
  5. sudoash macrumors member

    Joined:
    Jun 12, 2011
  6. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #6
    All I got sorry.
     

Share This Page