Error installing iTunes 6.0.1 on Win Xp

Discussion in 'Mac Apps and Mac App Store' started by StokeLee, Nov 12, 2005.

  1. StokeLee macrumors 6502


    May 30, 2005
    Stoke-on-Trent. Midlands, UK
    My friend on his windows xp machine has today just got round to upgrading from iTunes 6.0 to 6.0.1

    He downloaded it, ran the installation file and it said " installation file corrupt, please download a fresh copy" so he did this, and it said the same thing again.

    So i phoned my Dad, and got him to install iTunes 6.0.1, (he's never ever had it on before) and he got the same message.

    So we phoned Apple, and they said uninstall iTunes 6.0 and try again. Still no joy, and unfortunately, my friend hasnt got a back up of 6.0 so he cant play his music now.

    Has anyone else had this problem on a Win Xp machine? Does anyone know where to get a LEGAL copy of iTunes 6.0 from the apple website? My friend cant even find the CD that came with his iPod, i suggested he could use that a work around in the mean time.


  2. lolex macrumors member


    Nov 3, 2005
    where ever the Sun shines
    I 've seen several guys here report itune 6.1 setup errs on their pc,
    Quite a confuse to me , so yet dare not to update to 6.1.

    I kept a copy of itune 6.0 which I uploaded it as a torrent file :

    (Deleted, kainjow-Thanks for reminds me upload files here is illegal ) :)

    I'm not sure if this torrent works, since I upload it my first time.n would seeds for couple of days :)

  3. kainjow Moderator emeritus


    Jun 15, 2000
    Also that's illegal. You can't redistribute Apple software without their permission.
  4. blsbls macrumors newbie

    Nov 24, 2005
    iTunes installation files corrupt

    Here's a fix (that worked on my computer) that I found on another forum:

    OK so it sounds like your windows installer is corrupt ...... to repair corrupt Windows files use sfc /scannow ....... to do this put your XP cd in the rom drive, exit auto run, go to start > run ....... type in sfc /scannow (note the space between the c and the / )

    It takes a while to run but, as I said, it fixed my problems. Good luck...

Share This Page