Error installing Key Agent drivers in Windows 7

Discussion in 'Windows, Linux & Others on the Mac' started by Guy Jacobson, Nov 26, 2014.

  1. Guy Jacobson macrumors newbie

    Joined:
    Nov 26, 2014
    #1
    I recently reinstalled fresh Bootcamp (Windows 7 x64) on my iMac running Yosemite. However I'm having difficulty installing the drivers, I had to first bypass the issue with the x64bit drivers by running it through CMD as admin but I get the Errors

    "Service 'Key Agent/Mac HAL' (Keyagent/MacHALDrivers) failed to start. Verify that you have sufficient privileges to start system services."

    I have tried following the instructions that seemed to be the answer for this:

    I had the exact same problem, only on a 17" MBP. In my case, Win7 event manager reported that BootCamp 3.2 Services failed to install, in particular the KeyAgent service (and without that you get no Apple keyboard and functions and apparently the BootCamp icon doesn't show up in the system tray).

    Event Manager said the BootCamp installer did not have sufficient permissions, so I went to dial down the User Account Control (UAC) settings (in fact, I turned it off). What I should have seen when BootCamp 3.2 update was running was a window to ask my permission to continue (allow the software to install). Instead, there was a silent failure.

    OK, so by turning off UAC that gives it permission in advance (you have to reboot after changing the UAC settings in order to ensure that it is truly OFF). After rebooting, I went to Programs and Features and found BootCamp Services as a software item. I selected "Repair" and after another reboot, I was back in business! Keyboard is now fine (including the disk eject button, which I wanted working). Then I went back to turn on UAC to its default level (one notch below highest setting). It is useful (normally) to have this on.

    Ask the Windows Help system if you don't know how to find the UAC settings to give this a try. Hope it helps you.


    I have followed these instructions, tried on all different UAC settings, (including resets) and by running repairs on the program in Programs and Features and but rerunning it in CMD but the same evil error keeps getting in my way.

    Anyone had and solved this issue recently? Can you install these drivers another way?

    Regards.
     
  2. saturnotaku macrumors 68000

    Joined:
    Mar 4, 2013
    #2
    You're attempting to install an old driver set. 3.2 was designed for Windows XP and has long since been superseded by version 5.0. If your iMac is older, Boot Camp 4 drivers should also work. The driver packages are available on Apple's support website.
     
  3. Guy Jacobson thread starter macrumors newbie

    Joined:
    Nov 26, 2014
    #3
    Hi thanks for the reply, the text in italics was the answer I continued to find on online through many many searches, I'm on a iMac 20" 2008 model, with Mavericks and Windows 7 (x64) in my bootcamp. The drivers I'm trying to install the the recent ones downloaded to usb stick via bootcamp installer.

    Hope this clarifies?
     
  4. saturnotaku macrumors 68000

    Joined:
    Mar 4, 2013
    #4

    Do not use this method of obtaining the drivers. Download the package for your machine from Apple's website. Copy the .zip file to a separate thumb drive or DVD. After installing Windows, copy the drivers to that partition, unzip the file then run the installer.
     
  5. Guy Jacobson thread starter macrumors newbie

    Joined:
    Nov 26, 2014
    #5
    Thanks a lot Saturnoku! I used the 4.0 drivers and installed fine after bypassing the silly "bootcamp x64 is unsupported on this computer model" error. :)
     

Share This Page