error joining airport.....

Discussion in 'MacBook Pro' started by khan8822, Jul 6, 2007.

  1. khan8822 macrumors newbie

    Joined:
    Jul 6, 2007
    #1
    Hi

    I just purchased a new macbook few days ago,
    turned on the computer and connected to my router flawlessly without any setup.....now suddenly today it no longer connects and it gives me a message saying error joining airport "USR8054"

    I have no security enabled and my macbook can connect to all my neighbors routers EXCEPT for mine......my pc still connects to my router fine

    I resetted the router........restarted macbook.......googled the error for hours
    but i still cant solve the issue.....I don't know what to do

    Anyone have any ideas?
    first time mac user and I am not having a good start =(


    thanks
     
  2. aaronw1986 macrumors 68030

    Joined:
    Oct 31, 2006
    #2
    what type of router is it? Have you downloaded all os x updates? What about upgrading the router firmware? Strange that it worked, then stopped. Do you have MAC address filtering on or anything? You could always try resetting the router to default settings, not just unplugging.
     
  3. OutThere macrumors 603

    OutThere

    Joined:
    Dec 19, 2002
    Location:
    NYC
    #3
    I get that error when I try to connect to a network that is just barely out of range...my computer can see it but can't quite connect.

    I don't know if that applies to your situation or not, however.
     
  4. khan8822 thread starter macrumors newbie

    Joined:
    Jul 6, 2007
    #4
    Hi,

    The router is USR8054

    yep i always install all the updates
    I did a factory hardware reset
    I can't really upgrade the firmware, because the newer one is a beta version

    no filter of anything, completely open, broadcasted

    It is very strange and i have seen other threads in other forum that talks about it...........but no real solution.....


    I held the macbook right next to my router =P

    should i just reinstall my macbook with the CDs that came with it?

    thanks
     
  5. khan8822 thread starter macrumors newbie

    Joined:
    Jul 6, 2007
    #5
    anyone else have any ideas?

    otherwise i think i might have to return it and go back to pc =(
     
  6. keenkreations macrumors regular

    Joined:
    May 20, 2005
    #6
    I know that this might sound like a moot point, but have you updated the software on your Macbook? It might resolve the issues that you are having. Also make sure that you are not running MacStumbler or iStumbler while you are trying to connect. It can get a little wonky, from my experience.
    Also it wouldn't hurt to upgrade the firmware. On my Dlink, I had to update the firmware, even though it was beta. Sometimes these things are fickle like that. it could be interference...anything.
     
  7. khan8822 thread starter macrumors newbie

    Joined:
    Jul 6, 2007
    #7
    i upgraded my firmware on my router

    NOW IT WORKS! =)

    THANK YOU PEOPLE ~
     
  8. keenkreations macrumors regular

    Joined:
    May 20, 2005
    #8
    Ha I KNEW it! Don't be afraid of beta too much...its a lot better than alpha or Experimental releases. Now those are scary ;)
     
  9. BEET macrumors member

    Joined:
    Jul 7, 2004
    Location:
    Guernsey, Channel Islands
    #9
    frustration

    Congratulations that you got it working! However, I'm having a similar problem with my Macbook Pro. I've had it for a few weeks and it's had a full wireless connection for the whole time, until yesterday it stopped working.
    I've found loads of threads that relate to recent osx updates that have screwed around with router connection security.
    I've also tried resetting everything on the router and turning off the WEP (which actually worked briefly and gave me a wireless connection, until I tried to apply a WPA password and then lost the connection even when I disabled WPA again).
    Several if the threads I have looked at say to update firmware on the router, however my router is a DLINK DSL-G604T and the last update was in 2005 and has the most current version.
    This is really annoying! Do I need to waste money on another router? What makes it even more annoying is that my girlfriend has an old iBook which has full wireless connection throughout the house, which does confirm the a link with the recent OSX updates.

    any help would be very gratefully received!


    http://www.apple-discuss.com/viewthread.php?tid=931
     

Share This Page