Error loading /Library/InputManagers/SIMBL...

Discussion in 'Mac Programming' started by Cinder6, Aug 12, 2009.

  1. Cinder6 macrumors 6502

    Cinder6

    Joined:
    Jul 9, 2009
    #1
    I'm getting this message in the debug console in Xcode.

    I've done a bit of searching, and couldn't find anything that seemed directly related to this. Other solutions have said to remove the plugins, but this is complaining it can't find it at all. What gives?
     
  2. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #2
    What OS are you on? It GC is garbage collection. If you not using 10.5.x then this is not supported.
     
  3. Cinder6 thread starter macrumors 6502

    Cinder6

    Joined:
    Jul 9, 2009
    #3
    I'm on 10.5, and my project's target is set to 10.5.
     
  4. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #4
    Ah, interesting. So is your project set as GC enabled? If so then I would suggest that SIMBL is not...
     
  5. Cinder6 thread starter macrumors 6502

    Cinder6

    Joined:
    Jul 9, 2009
    #5
    Yeah, GC is on. Problem is I have no idea what the SIMBL thing is.

    Edit: Whoops, I left out one critical word in the message: "GC capability mismatch". I found this thread, but I don't see that it really helps me fix it.

    EDIT 2: Okay, I think I've figured it out, and it's not going away unless I uninstall Glims (which is the only InputManager I have installed). So, how do I suppress this warning?
     
  6. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #6
    It's not a warning. It's a hard error. Either uninstall that dodgy crap (SIMBL is really one giant big hack) or switch on/off GC in your app (whichever is required). Note if you currently have it switched on and have to switch it off you will have to do proper memory management for all your objects.
     
  7. Cinder6 thread starter macrumors 6502

    Cinder6

    Joined:
    Jul 9, 2009
    #7
    Alright. I looked into what I had installed that was using SIMBL, and it turns out it was all for Safari, which I don't use anymore. So SIMBL is gone now, and so is the error. Thanks.
     

Share This Page