Error message installing Win 7 on iMac i7

Discussion in 'Windows, Linux & Others on the Mac' started by filmfreak71, May 21, 2011.

  1. filmfreak71 macrumors newbie

    Joined:
    May 21, 2011
    #1
    Hi guys,

    I just received my brand new iMac i7 a few days ago and it is really is an awesome machine. However, I've run into serious problems installing Windows 7 64 bit via bootcamp. Every time I try, I get to the point where it is expanding and then it pops up with error message 0x80070570. What's really weird is that it happens at random between 1 and 30%. I seen various suggestions to try different makes of blank disc and re-try downloading the disc image. I've now done this numerous times and the only thing I can get to work is use the 32bit version, but with 16gb, I'd much rather have the 64bit version.
    Do anyone know if there are any problems with 64bit Win 7 on the new 2011 iMacs?
    Cheers
     
  2. Quad5Ny macrumors 6502a

    Quad5Ny

    Joined:
    Sep 13, 2009
    Location:
    New York, USA
  3. erikkadeb macrumors newbie

    Joined:
    May 19, 2011
    #3
    works with Parallels

    I have a new Imac 27 (i7-2600 CPU @ 3.40 GHz), Windows 7 64 bit works great with Parallels.
     
  4. filmfreak71 thread starter macrumors newbie

    Joined:
    May 21, 2011
    #4
    Tried that, still no joy, it fails in exactly the same way :(

    The only thing I can get to work is my official 32bit disc version, I have a Microsoft Action Subscription Pack which gives me all version of Windows but they only sent me the 32bit version hence no 64bit version.

    I just can't believe it is this difficult to get it installed. It looks like I'm going to have contact MS and get them to send me a 64 bit disc based copy and make do with the 32bit version for now :mad:
     
  5. Bo Duke, May 23, 2011
    Last edited: May 23, 2011

    Bo Duke macrumors newbie

    Joined:
    May 23, 2011
    #5
    Hmm, I installed Bootcamp (windows7 64bit) on my new 27" Imac i7 2011 with 4gb of ram no problem. Breezed through all the install and setup.

    Then added 8gb of ram a week later to take it up to 12GB and shortly after this I had a blue screen death and on restart it was flagging errors on the drive which it corrected with the normal windows disk check.

    However more problems happened with programs crashing etc so i decided to rebuild the BOOTCAMP partition and start again.

    When i go through the reinstall process im getting exactly the same problem you are filmfreak. I get so far into expanding the files and i get a similar error message.

    Seems odd that it worked with 4gb of ram and didn't with 12gb of RAM so i might try installing it again later after taking the ram out.

    By the way, the OSX partition is completely fine and working 100% in all programs.

    UPDATE: FIXED (for now)
    Ok, tried removing the original 4GB and leaving in the new 8GB. Same problem when installing windows 7.
    Removed the new 8GB and put just the original 4GB back in. It worked!!

    Tested the memory 8GB and it was giving out faulty addresses. So for me it was the new Crucial memory I had bought that was the problem.

    Hope this is some use to you...
     

Share This Page