Error message: Song can't be played because you're not logged in to Apple Music

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by mgpg89, Aug 18, 2015.

  1. mgpg89 macrumors 6502a

    mgpg89

    Joined:
    Aug 31, 2008
    Location:
    Belgium
    #1
    New day, new bug.
    I get this weird error message when I try to start a playlist:

    Song can't be played because you're not logged in to :apple: Music.
    You have to be logged in to :apple: Music before you can play :apple: Music songs.
    This doesn't happen to all :apple: Music songs, just some of them.
    Wasn't able to figure out a pattern yet, if there is any.

    Obviously, I am logged in.

    Already tried:
    • logging out and then logging back in again.
    • playing on iPhone works fine.
    Anyone got any ideas how to solve this?
    Thanks in advance.
     
  2. mgpg89 thread starter macrumors 6502a

    mgpg89

    Joined:
    Aug 31, 2008
    Location:
    Belgium
    #2
    Anyone? The problem keeps persisting. Been 3 days now.
     
  3. Julien macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #3
    You probably should provide more info if you want others to help you troubleshoot.

    • Is it on your Mac or iPhone or both?
    • Did you try rebooting your Mac and/or iPhone?
    • Is it happening on more than one device?
    • Are you playing music on your Mac at the same time you try on your iPhone?
    • Are you running any betas?
    • Are all tracks your are trying to play available in Belgium (not grayed out)?
    • Are these tracks you have played before?
     
  4. mgpg89 thread starter macrumors 6502a

    mgpg89

    Joined:
    Aug 31, 2008
    Location:
    Belgium
    #4
    Answered!
    Thanks for helping out
     
  5. mgpg89 thread starter macrumors 6502a

    mgpg89

    Joined:
    Aug 31, 2008
    Location:
    Belgium
    #5
    Ugh, this is really starting to get on my nerves.
    Can you call Apple technical support for Music issues?
     
  6. mgpg89 thread starter macrumors 6502a

    mgpg89

    Joined:
    Aug 31, 2008
    Location:
    Belgium
    #6
    Managed to solve this one myself ... after a couple of nerve-racking days.
    Doesn't seem to be a widely-documented problem,
    but here's the solution anyway.

    The problem only occurred with tracks that were made available offline on my Mac.

    Steps to fix this:
    1) delete download (don't delete the music, just the offline file)
    2) play.
    3) re-download if you'd like

    Voila -_-

    Something seems to have corrupted the downloaded files that caused them not to play anymore.
     

Share This Page