error message: "The FlashResource file is missing"

Discussion in 'Mac Basics and Help' started by Becko, Jun 17, 2010.

  1. Becko macrumors member

    Jan 29, 2010
    Flash CS5 is giving me an error message "The FlashResource file is missing" I did some google investigation, this was the most accurate info I could find:

    So yeah.. I too used CleanMyMac app and deleted italian language.. I don't know who is more guilty if flash programers for programming this way, or cleanMyMac app for not being able to recognize this kind of not-only-language folder... or maybe I'm guilty as well...

    anyways... could someone please email me (zip) the file "it_IT.lproj folder" ? so I can re-install it back to its rightful place.

    I don't know if is possible to duplicate a folder file though...

    Thanks in advance
  2. BlueRevolution macrumors 603


    Jul 26, 2004
    Montreal, QC
    My Flash CS5 install doesn't have the Italian localization at all, just en_US.

    Attached Files:

  3. Becko thread starter macrumors member

    Jan 29, 2010
    You are right is not italian but the "en_US.lproj" folder,

    Finally I was able to fix the problem, one of my teachers passed me the folder "en_US.lproj" which contains the following 3 items: "Localized.rsrc" "mfc2pp.strings" and "workspace.strings"

    So I restored the folder to its original location and now Flash is working back to normal and thankfully I didn't have to re-install it.

    Although I have both CleanMyMac and Monolinguial apps, I guess it was my fault since while using Monolingual I only kept "English" language enabled from NOT being deleted, but I did removed the "English United States" language... my thought was, "why would I need two english languages ?" Anyway I learned my lesson with these proj files... and I'm so glad I didn't select any architecture to delete while using monolingual.

    To be honest it is not a safe bet to use monolingual... how can someone know if a heavy app such as Flash is programmed this way... with strings files on languages folders ?
  4. ice40i macrumors newbie

    Jun 18, 2010
    you think theres any way you can email me that folder the exact same thing just happened to me i would be much appreciative and give you infinite internet points!!!
  5. BlueRevolution macrumors 603


    Jul 26, 2004
    Montreal, QC
  6. papernapkin macrumors newbie

    Jun 23, 2010
    I'm having the exact same problem and the culprit must have been CleanMyMac as well. Do you think you could post that folder again? It seems the link above is dead now? I would REALLY appreciate it. Thanks!
  7. algy! macrumors newbie

    Jul 24, 2010
    Can you please reupload BlueRevolution!
  8. blunderboy macrumors 6502

    Feb 13, 2010
    Completely unrelated, but I think the Dalek Caan/K9 icons are awesome. Doctor Who ftw. :D
  9. BlueRevolution macrumors 603


    Jul 26, 2004
    Montreal, QC
    Sure. I'll do it later today. Sorry, I don't usually leave stuff in my public folder for too long at a time.

    Thank you. My other hard drives/partitions are TARIDS, Mummy, and Sonic. All of the icons come from this set.
  10. Pilsbury1981 macrumors member

    Sep 23, 2008

    I to have a problem like this. can open internet pages but the videos don't play? i have tried re installing flash from the adobe website but it just comes up Image data corrupted?

    Is this the same thing? how do i solve it?

  11. algy! macrumors newbie

    Jul 24, 2010
    No, we're talking about Flash Creative Studio. You can use it to create flash games, animations etc.

    (Even though this is the wrong post). Does image data corrupted come up when your computer tries to mount the disk?

    Thanks, please can you post the link!
  12. RevBus macrumors newbie

    May 23, 2010
    bump.. getting this error, could someone post a working link for the files CleanMyMac removes?
  13. algy! macrumors newbie

    Jul 24, 2010
    Yes PLEASE repost!
  14. mrpuffy macrumors newbie

    Sep 4, 2010
  15. algy! macrumors newbie

    Jul 24, 2010
    With a recent Flash update, I have no problems anymore! I'd recommend anyone with the same problem to update!
  16. mtydfboy macrumors newbie

    Feb 10, 2011
    OH NO!!! also missing the en_US.lproj

    Hey BlueRev, could you reupload please?????, I tried to open my Flash CS5 and got the same problem. The ugly part is that I'm not at home and can't access my installer
  17. MacTasty macrumors newbie

    Apr 1, 2011
    If you have a Time Machine backup you can just go back to before you used the language cleaner app and restore the Flash file from there.

    I was having the same problem after using Monolingual and this is how I fixed it.
  18. Yoast, Apr 5, 2011
    Last edited: Apr 5, 2011

    Yoast macrumors newbie

    Apr 5, 2011
    I'm very sorry to bump the thread like this, but I'd very much love having this resources file again. I too have fallen victim to monolingual. Once and never again.

    EDIT: I went ahead and downloaded the Free Trial. It replaces the lost folder described above. I've also hosted the folder. It's EN-international nationalisation though, not italian. You can find it here:

    If it goes offline because I (accidently) remove it and you need it, just send me an e-mail.
  19. Marquinhios macrumors newbie

    Jul 9, 2011
    Please, could anyone to share the file w/me?...
  20. usa132 macrumors newbie

    Jul 19, 2011
    Hi BlueRevolution. Could you please reupload the language folder for CS5 flash. I need it for the same problem with FlashResources.

  21. aberling macrumors newbie

    Aug 26, 2007
    Another one bites the dust...

    I just did the same D#*n thing. I tried to find the files on my other Mac, but it doesn't show them in a search. Does anyone still have them? Could you post them..pleeeeeze with sugar on top?

  22. Marquinhios macrumors newbie

    Jul 9, 2011
    aberling, I reinstalled flash... no timemachine, no copy ********** files/folders
  23. jacobtdodge macrumors newbie

    Jan 25, 2012

    Could you pretty please repost files on drop box! :)
  24. nb00581 macrumors newbie

    Mar 16, 2012
    Just made the same stupid mistake of using monolingual without deselecting my Adobe apps! Could someone pleeease repost the above mentioned missing en_US.iproj files or mail them to me; would really really appreciate it! :confused:
  25. boyciesdog macrumors newbie

    Jul 10, 2011
    error message: "The FlashResource file is missing"

    Could someone please repost this file. I'm in the same situation and I'm having issues downloading Flash through Adobe Air.

Share This Page