Error on boot up - Unable to find drive for this platform

Discussion in 'MacBook Air' started by MacNoob815, Oct 16, 2013.

  1. MacNoob815 macrumors newbie

    Joined:
    Oct 16, 2013
    #1
    Hi,
    One of our users has a problem with his MacBook Air. Upon booting, he gets an error message saying:

    Panic (cpu 0 caller 0xffffff802e259241): "Unable to find driver for this platform:\"ACPI\".\n"@/SourceCache/xnu/xnu-2050.20.9/iokit/Kernel/IOPlatformExpert.cpp:1548.....BSD process name corresponding to current thread: Unknown.

    To give you some background, he had an iPhone with a locked sim (they were trying to retrieve the pin) and he contacted O2. O2 told him to connect the iPhone to the MacBook Air, which was working correctly at the time. He said that the MacBook seemed to start a download or update of some sort and the next time it restarted, it had this error.
    I have tried pressing CMD + S at startup in order to try fsck -y and it presents me with screen saying Loading drivers........and then a similar screen to the one above and won't accept any input. I tried CMD + OPTION + O + F at startup but couldn't get to the EFI. Can you tell me if I need third party software instead and if I go messing with the EFI, will I void the warranty?

    Thank you very much in advance for any advice that you can provide,
    Justin Forde.
     
  2. wolfpuppies3 macrumors 6502

    Joined:
    Jun 26, 2012
    Location:
    Virginia, USA
  3. PBG4 Dude macrumors 68000

    PBG4 Dude

    Joined:
    Jul 6, 2007
    #3
    I did a quick internet search of your basic error. So far the only useful solution has been to reinstall the OS from the recovery partition.

    a core driver for your computer (ACPI is power management so low level stuff), has become corrupted, and you'll need to replace the corrupted file.
     

Share This Page