Error Setting up Sync Between Calendar (iCal) and Google

Discussion in 'OS X Mountain Lion (10.8)' started by jazmagirl, Oct 13, 2014.

  1. jazmagirl macrumors newbie

    Joined:
    Oct 13, 2014
    #1
    Hi there,

    I am trying to set up a two-way sync between my (many) calendars on iCal and my Google Calendar. I have spent hours on this task, on multiple occasions, and following the instructions on multiple forums and blogs... but to no avail.

    My largest problem seems to be that iCal will not recognize my Google username/password credentials, even though I am positive I am entering them correctly. I have tried entering them through the iCal program and through the "Mail, Contacts, & Calendars" section of System Preferences. These are the errors I receive, respectively:

    "Calendar found a CalDAV server but couldn't log in with the user name "myusername@gmail.com". Make sure the user name and password you entered are correct, then try again."

    and

    "Unable to verify account name or password."


    Is there anyone here who could suggest a possible cause/solution to this issue?

    Please note, the username/password credentials I am entering are correct. I even logged out of google and logged back in using the credentials to double-check that they worked. They do.

    Another bit of information that may help: I tried this with my 3 google accounts. My two accounts that end in "@gmail.com" did not work, but my account that ends in "@maine.edu" (even though it is a domain that functions through google) did work. Hmm... Is there anyone here who knows why google and iCal won't sync?
     

    Attached Files:

  2. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    Not running ML here and I don't recall an ML/Google Calendar specific issue.

    I have seen a specific Google account's calendar refuse to work with a Mac running Leopard.

    Try:
    1. Removing the accounts
    2. Deleting any Keychain entries relating to the two troublesome accounts
    3. Re-add the accounts

    You could otherwise be having an issue involving some lingering System files.
     
  3. limcraw macrumors newbie

    Joined:
    Sep 24, 2015
    #3
    I've been working on this for hours, and just found the issue.

    To remedy this:
    1. Log in to your gmail.
    2. Click your picture at the top a select my account.
    3. Select the sign in & security option.
    4. Scroll to the bottom and toggle 'allow less secure apps' to ON.

    That did it for me!

    Good luck.
     
  4. HardyC macrumors newbie

    HardyC

    Joined:
    Jan 30, 2017
    #4
    Halle-freakin'-lujah! Thank you, limcraw!

    I'd toggled it to OFF recently when presented with a bunch of options as I was setting up a google account on a new tablet. By the time I sat down to my MacBook Pro a day later, iCal was acting funky and offering no valid explanation why it should suddenly not interface with google servers (or why google wouldn't acknowledge the known-good password and configurations).

    Thrilled to have stumbled upon your solution (which, naturally, clicked the lightbulb of recognition about the 'allow less secure apps' option) after too many hours of trying to dump caches, calendars, keychains, plists -- I'm thankful that all that nuclear-option activity doesn't seem to have disturbed anything else on my Mac.

    Thank you, again!
     

Share This Page