Error streaming HD content

chrischa

macrumors newbie
Original poster
Oct 23, 2012
1
0
Hi,
Looooong time lurker, first time poster! :D I just bought an Apple TV 3 and upgraded to OS 5.1. Whenever I try to view movies or TV in HD (720p or 1080p) I almost immediately get the message: "An error occurred loading this content. Try again later". If I switch to Standard Definition in the store settings then the content loads without a problem.

I tried calling Apple Care and the first guy I spoke with made it sound like there is currently an issue going on with Apple's servers. However, when I spoke to a senior advisor he said it was most likely my WiFi connection. I'm getting WiFi d/l speeds of around 6Mbps. Shouldn't that be more than fast enough to stream 1080p content given a couple minutes of pre-buffer time?

1080p streaming has worked a couple of times but it's very inconsistent and error prone. Has anyone else seen this occur recently or after upgrading to 5.1?
 

Kalina

macrumors newbie
Jul 23, 2008
3
0
I'm having the exact same issue. HD gives me a error, SD plays fine. I thought it was the new firmware, but I downgraded and I have the same issue. Do you think its a issue with their server? This has been going on for 2 weeks.
 
Comment

Kalina

macrumors newbie
Jul 23, 2008
3
0
Ok, this is the stupidest solution yet.
I've tried:
-Downgrading the firmware
-upgrading the firmware
-restarts/unplugging
-wired connection
-wireless connection
-different networks

What finally worked for me, was logging into my apple id online (on their site and on itunes) and changing my username and password. Suddenly everything works again.

I don't know why.
 
Comment

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.