error"The home folder for user "xxxxxxx"

Discussion in 'Mac OS X Server, Xserve, and Networking' started by djbetterly, Apr 2, 2010.

  1. djbetterly macrumors newbie

    Jan 4, 2005
    I keep getting this error"The home folder for user "xxxxxxx" isn't located in the usual place or can't be accessed." The home folder has been set, DNS, forward and reverse is working fine as well. What am I doing wrong?
  2. padawer macrumors newbie

    Aug 10, 2010
    Sorry for the repost, but this problem can cause someone to believe they have lost data, reformat, etc. I'm hopeful that this repost will save someone the trouble, although I apologize for the redundancy.

    I had the same problem, and a VERY QUICK AND EASY solution created by Thomas Tempelmann elsewhere worked for me. (In my case, I also saw the dialog box that said, "The home folder for user "xxxxxxx" isn't located in the usual place or can't be accessed." As an aside, I suspect the problem may have arisen when two hard disks shared the same name "Macintosh HD" although I'm not entirely sure of that being the cause.)

    SOLUTION that worked for me:
    1) Open the
    2) Type this and then press return:
    sudo xattr -d /
    (note: don't leave off the last space and "/" character before pressing return)
    3) It should have asked for your password. Type it and press return.
    4) Now do nothing else, except quit and then RESTART your computer (select "Restart" from the Apple menu)

    More about the original problem Thomas described (identical to mine): "Finder shows empty desktop, and even an 'open /Applications' in Terminal does not open a window. Furthermore, 'open /' leads to the message that 'The alias <diskname> can't be opened because the original item can't be found'."

    I had almost given up hope, but this simple command that resulted in a repaired "" file did the trick for me. I hope this works for you.

Share This Page