Error Updating/Restoring iPhone Error No 20

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mealybar, Jul 11, 2008.

  1. mealybar macrumors newbie

    Joined:
    Oct 30, 2007
    #1
    My phone failed the 2.0 update so is trying to restore back to 1.1.4 but it goes through the 'Extracting Software' and then comes up with a 'iPhone could not be restored. An unknown error occurred (20).'

    How do I get my iPhone back even if it's to 1.1.4?
     
  2. bigrash macrumors regular

    Joined:
    Jan 23, 2008
    #2
    Same thing happened to me yesterday when I was trying to update using the unofficial firmware. I tried reinstalling the firmware again and it worked the second time.

    I read on apple's support forums that some people had the try a few times in order for it to work.
     
  3. justmattyg macrumors newbie

    Joined:
    Aug 18, 2006
    #3
    I'm in the exact same boat you are.

    Everytime I go to restore my iphone, it chooses the old 1.1.6 old firmware and displays that same message you have received.

    I've called support several times, and they insist its a server issue. I'm pissed because they are lumping my issue with itunes into the 6 billion other people that are having trouble downloading 2.0 software.
     
  4. mealybar thread starter macrumors newbie

    Joined:
    Oct 30, 2007
    #4
    I spent some time at work checking through the errors that people were having and never spotted an error 20. Mine isnt a Jailbroken phone either.

    I havent heard of software 1.1.6, all I get is instructed to try 1.1.4.

    I'm downloading the 2.0 software from the macrumors front page and will try the manual Option-Restore to try and update it out of this cycle of error 20's.
     
  5. detroitpimp421 macrumors newbie

    Joined:
    Mar 4, 2008
    #5
    i have a 1st gen iPhone and today i tried to upgrade to the 2.0 software.
    i plugged my iphone into my comp and opened itunes, i then dowloaded the software and now itunes says....itunes has detected a iPhone in recovery mode and you must restore before you can use it with itunes. so then i hit restore and press restore and update. then it extracts the software and wen it finishes with that says....The iPhone could not be restored. An unknown error occurred (20).

    please help
    i cant get it
    thanks
     
  6. mealybar thread starter macrumors newbie

    Joined:
    Oct 30, 2007
    #6
    Keep trying.

    Dont let it even try and download and restore to anything but 2.0. When I finally got it to download 2.0 mine started working again.

    Although I've lost all my settings, text messages etc - guess the backup before the initial restore failed :(
     
  7. kalamus macrumors member

    Joined:
    Dec 28, 2006
    Location:
    Grand Prairie, TX
    #7
    Ive seen a couple posts that if you tried to install the 2.0 early in the morning that it may have borked your 2g iPhone. One poster said that the CS rep said he needs to get his repaired. I hope this isnt true because it would be a pain in the arse to send this in for repair. Im currently on hold with iPhone CS.

    Mine still wont even get past the restore to 1.14 firmware. Keep getting 1604 error then immediately after that I get error 6. Not sure what thats about. Ive tried at least 30 times to redock the iphone and restore it to no avail. Its really starting to irritate me now. Almost 12 hours of a brick iPhone. Pretty damn disconcerting coming from Apple. :(
     
  8. justmattyg macrumors newbie

    Joined:
    Aug 18, 2006
    #8
    yep, im in the exact same boat. I was referred to a very sweet customer service lady that assured me if i took it to the nearest apple store (1.5 hours away) the repairs would be taken care of. She did strongly suggest if I had ever ever unlocked the phone that it voided any service warranty and they would not have anything to do with it.

    Its obvious that their 2.0 update has completely effed my firmware enough that it requires hardware replacement. This seems like poor planning on apples part, then again, today has made that very clear. lol

    good luck kalamus, be sure to let me know how yours turns out
     
  9. kalamus macrumors member

    Joined:
    Dec 28, 2006
    Location:
    Grand Prairie, TX
    #9
    Im still having problems. I was on the phone with an apple CS rep for an hour. I signed in as a different user to try and restore and that didnt work. She put me on hold and after 15 mins of being on hold she hung up and never called me back..... now im really steamed. She has my number just is choosing to not call me back because she cant fix my problem. This is complete and utter horse ****. You better your ass im going to go the the nearest Apple store sometime tomorrow and crack some skulls.
     
  10. klubboi17 macrumors newbie

    Joined:
    Jul 12, 2008
    #10
    Here's what i did to fix this

    i installed itunes on my pc took out my sim card.... ( this is the key to restoring) plug the iphone into the pc and itunes took over from there...it will install the 2.0 firmware and reboot when its done it will say can not activate the phone this is due to the sim card not being in the phone.. just put the sim card back in and plug phone back into your computer that just restored the 2.0 and it will activate your phone and your set... hope this helps.. it sucks when you struggle for hours to find a fix
     
  11. boy17ro macrumors newbie

    Joined:
    Jul 12, 2008
    #11
    iphone error (6) fix

    so, same problem, i wanted the new 2.0 firmware on my iphone, it bricked, really bad, i tryed restoring to everything, 1.1.1 1.1.2 1.1.3 1.1.4 and keept getting everithing from error (6) to (9) to (20) and to 16**, i don`t know if it only worked for me but this is what i did, i took out the sim card, and installed ziphone, docked the iphone and in ziphone ADVANCED FEATURES chose DFU mode, then in itunes i restored it to firmware 1.1.3 the only one that worked only after it installed it sayd refreshig firmware and crashed, error bla bla bal and showed me the usb cable on the iphone, nevermind that, the software is installed u just can't see it, go to ziphone and click on DO IT ALL, after that. happy happy joy joy it worked, i`m now on 1.1.3 firmware, i used to be on 1.1.4, tryed to upgrade to 1.1.4 and bricked the phone again, but did the whole ziphone 1.1.3 and worked, so i did it twice and it worked for me, hope i`t's useful sorry abut the mistakes i`m from romania
     
  12. airfly macrumors newbie

    Joined:
    Jul 13, 2008
    #12
    I got the same error no. (20) when I tried to restoere to 1.1.4 from 2.0(official firmware) just now. Then I restored to 2.0 firmware again. Then I restored to 1.1.4 again, this time I got error no. 1601.:eek:
     
  13. Kwill macrumors 68000

    Kwill

    Joined:
    Mar 10, 2003
    #13
    Finally successful update (caveat)

    My firmware update (1.1.4 to 2.0) eventually occurred on the first day when servers were overloaded. Restoration from backups was incomplete. Songs would not load and new apps would not launch.

    Last night I took the extreme measure of completely erasing my iPhone. (Perhaps this was not necessary.) This morning when taken to the Restore screen in iTunes I selected "Set up as new iPhone" instead of "Restore from backup." Because I first erased my iPhone, all my original Web apps, user preferences, favorite contact list, and notes are gone but now all other personal data is there. Songs and Web apps and everything else is now working.

    I also activated MobileMe service. When doing so, make certain you do not also sync contacts, calendars, etc. from iTunes otherwise there will be duplicates. You don't want to sync over the air AND when connecting your iPhone.

    Tiger 10.4.11
     
  14. tom6065 macrumors newbie

    Joined:
    Jul 23, 2008
    #14
    iphone error 20

    can someone help my im trying to restore my iphone to 1.1.4 but i cant error 20??? can someone help me??
     
  15. beankid1025 macrumors newbie

    Joined:
    May 21, 2008
    #15
    anyone find an answer to this? I have run into this error 20 myself and can't seem to find a way to get my phone back to 1.1.4
     
  16. elmote macrumors newbie

    Joined:
    Jul 31, 2008
    #16
    suggestions based on my success at recovering from this

    OK I finally recovered from the same problem you guys are having. This is what I had to do:

    I use a MAC but to recover I used a POS PC running Vista. I installed ITunes 7.4 on the PC and I transfered a copy of 1.4.1 ipsw (you should use whatever the firmware version you had installed on your IPhone before you tried to upgrade to 2.0).

    You MUST make sure you enter DFU mode on the IPhone, not recovery mode but DFU, it WILL NOT work if you are just in recovery mode. Once ITunes goes to the recovery screen (it will do this even if you are NOT in DFU mode so again, make sure you are in DFU mode) then hold down the shift key on the PC and click restore and select the 1.4.1 IPSW file or whatever your previous IPSW version was.

    Go through the restore process and it should complete. It worked for me and then I actually successfully completed the 2.0 upgrade using the PWNAGE tool using my MAC. I screwed up my original 2.0 upgrade by interrupting the IPhone when it was doing a base band flash, which is the worst case scenario, so if I can recover from that anyone should eventually be able to recover their IPhone so don't lose hope.

    Hope this helps.
     
  17. elmote macrumors newbie

    Joined:
    Jul 31, 2008
    #17
    correction for IPSW version

    Sorry on my above post I typed 1.4.1 instead of 1.1.4.
     
  18. jrigga macrumors newbie

    Joined:
    Aug 16, 2008
    #18
    Ok I finally got 2.0 working using winpwn

    Like everybody on here I bricked the heck outta my phone when i did the update to 2.0 After about 4 hrs of pulling my hair out i found my mistake and corrected it, and it finally loaded everything the way it should be now I have 2.0 on a second gen. iphone that previously had 1.1.3 on it. I never went to 1.1.4.
    *the Problem* I used the instructions that Ive found all over the net. it seems to be either from DEV team or another reliable source. You know, it steps you through with screen shots. Well about step 11 or 12 its says that you should open the custom IPSW file that you make, and I tunes should open up with a window saying "itunes has been Pwned!" well I never saw that message. ***UPDATE*** as i was typing this I went back to the sites that i found the instructions and they have been updated!! They area correct now! any how the step that was left out of the original instructions was to make sure after you build your custom file that you hit the IPWNER button, this is what hacks itunes and makes it possible for you to read the new custom files without getting all those darn errors like I did...This is my first post ever! hope its not to long, but just thought it might help somebody!
     
  19. gloskris macrumors newbie

    Joined:
    Aug 23, 2008
    #19
    My original frimware was 1.1.1 then i upgraded to 1.1.2 then straight too 1.1.4 easy as anything. Anyway this new app has just come out that you have to buy Dynolicious but i requires 2.0.2 to work so i thought sod it i'll upgrade to that firmware, researched into it before i do it and not **** up and guess what it ****ed up.

    I even put the phone into DFU mode and restore and still i get error 1015,1016,20.

    I've tried ziphone,ibrickr,pwnage and still no luck my phones stuck in 2.0.2 recovery mode and it's useless to me at the moment. Need some help quick
     
  20. gloskris macrumors newbie

    Joined:
    Aug 23, 2008
    #20
    right i've managed to get the errors to stop coming up.

    Put phone into DUF mode (blank screen) load ziphone up Do it all
    and it's done ziphone wont detect the iphone when its in recovery mode for some strange reason, now i'm back to 1.1.4 and when some one finds an easier way to upgrade to 2.0.2 then ill do it then for now tho 1.1.4 ftw
     

Share This Page