Error updating to 2.0.1

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Mkallevik, Aug 5, 2008.

  1. Mkallevik macrumors member

    Joined:
    Oct 26, 2007
    #1
    Tried to update my iPhone 3g to 2.0.1 last night and got an error. Now the iPhone is in recovery mode and when I try to restore it I get unknown error 1604 and it stops.

    I have searched around and I found that Apple has a support page for this, but none of the resolutions are helping me. Here is the support page: http://support.apple.com/kb/TS1275

    I live in Norway and there are no genius bars or whatever here.

    Edit: I have tried to restore it on two different macs. One macbook air and one macbook. I have tried to restore to 2.0. I have tried to reinstall iTunes. I have tried to make a new user account on my mac. I have tried putting it in DFU mode to restore it.

    What to do?
     
  2. KidHoliday macrumors newbie

    Joined:
    May 8, 2005
    #2
    Same thing happened to me

    I clicked the update button and then got an "error 9" it then tried to restore itself, but got another error, killing my iphone in the process.

    I live in the States and work across the street from an AT&T store (our carrier). I ran right over and a nice young lady by the name of Chantelle made sure I wasn't up to any funny business by checking for the original sim card, then she plugged in the phone to a computer behind the counter.

    I don't know what she did, but she got my iphone 3G working again, blanking it's memory in the process. Once I restore it however, I should be back in business.

    My advice is to take it to your local carrier, if you live too far from an Apple store.

    Best of luck!
     
  3. Mkallevik thread starter macrumors member

    Joined:
    Oct 26, 2007
    #3
    Bumping this thread because my nearest carrier store is two hours away. (In Norway they chose to sell iPhone in just the biggest city´s for now)

    Anyone have something I can try?
     

Share This Page