Error when SSH into iPhone

Discussion in 'Jailbreaks and iOS Hacks' started by sepandee, Feb 14, 2011.

  1. sepandee, Feb 14, 2011
    Last edited: Feb 14, 2011

    sepandee macrumors regular

    Joined:
    Jun 11, 2007
    #1
    I thought I couldn't SSH into my iPhone because I had changed the password and didn't remember it anymore. However, after trying to change the password in MobileTerminal, I realized that it was indeed set to the default pw (alpine).

    So what am I doing wrong?

    In Cyberduck or FileZilla, I open a new connection:

    * SFTP
    * Server: copy the IP address under Settings > Wifi > My Wifi connection. Mine is 192.168.10.198.
    * Port: 22
    * Username: root
    * PW: the password that I just chose.

    In Cyberduck, it gives the error "I/O Connection Failed. Connection timed out"
    Edit: Actually, now it says "I/O Connection Failed. Premature Connection closed."
    In FileZilla, the error is "Server unexpectedly closed network connection. Could not connect to server."

    What am I doing wrong?
     
  2. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
  3. sepandee thread starter macrumors regular

    Joined:
    Jun 11, 2007
    #3
    Yes, I do.
     
  4. Bl0ckHe1d macrumors 6502

    Bl0ckHe1d

    Joined:
    Nov 19, 2009
    Location:
    Caledonia
    #4
    do you have it switched on via sbssettings?

    in my experience it took a few attempts to open the ssh link - keep trying!
     
  5. sepandee thread starter macrumors regular

    Joined:
    Jun 11, 2007
    #5
    Is that the SSH button? If so, yes, it's green but who knows... a lot of times the 3G button is green but I'm not connected to the 3G network.
     
  6. ich1ban macrumors regular

    ich1ban

    Joined:
    Jun 17, 2006
    #6
    Yeah make sure this is on ^

    Do you have to enter a port #? I use Fugu and never had to.
     
  7. Bl0ckHe1d macrumors 6502

    Bl0ckHe1d

    Joined:
    Nov 19, 2009
    Location:
    Caledonia
    #7
    yip that is the one and it should be green if you wish to ssh...your wifi should be green too for that matter!!
     
  8. sepandee thread starter macrumors regular

    Joined:
    Jun 11, 2007
    #8
    Actually, now it says "I/O Connection Failed. Premature Connection closed."

    And I'm trying to reinstall OpenSSH, but it I keep receiving errors in Cydia:

    http://apt.saurik.com
    POSIX: Operation timed out
     
  9. sepandee thread starter macrumors regular

    Joined:
    Jun 11, 2007
    #9
    3G was off the entire time. So was E. I just tried it again with them on and off.

    I don't even care about SSH. I just want to format my iPhone but I have some cycorder videos that I need to transfer to my computer. If there's another way to do this, I don't mind.
     
  10. Bl0ckHe1d macrumors 6502

    Bl0ckHe1d

    Joined:
    Nov 19, 2009
    Location:
    Caledonia
    #10
    being padantic here - this may not be the problem however the iphone is case sensitive try changing the upper case R on Root to lower case r root

    ie
    * Username: Root
    change it to * Username: root
     
  11. Bl0ckHe1d macrumors 6502

    Bl0ckHe1d

    Joined:
    Nov 19, 2009
    Location:
    Caledonia
    #11
    have you tried iphone explorer?

    http://www.macroplant.com/iphoneexplorer/
     
  12. sepandee thread starter macrumors regular

    Joined:
    Jun 11, 2007
    #12
    Sorry it was 'root'. Don't know why I said Root.
     
  13. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #13
    Just to be clear, you're on the same wifi network your computer is on right?
     
  14. 328iGuy macrumors member

    Joined:
    Mar 3, 2009
    #14
    I have the same issue, it's really odd, to get it to work I need to go to Cydia and reinstall openSSH, then it works immediately without issue, however if I try to connect again 20 minutes later, same error and need to re-install to get it to work?

    I assume this is the same issue you are having as well?

    If you haven't tried, try re-installing, I bet you can then temporarily connect again?
     
  15. sepandee thread starter macrumors regular

    Joined:
    Jun 11, 2007
    #15
    Yes
    I have actually tried to reinstall openSSH, but ...
    Well, I was going to say 'but it always gives some errors during the process, even though it does finish the installation.' Now I tried to reinstall again and for some reason, it worked this time. I don't know why, but must've been because I was playing around with Cydia yesterday updating some stuff.

    And after that, I tried to SSH into my iPhone and you know what? It now works :) Thanks.
     

Share This Page