Error when trying to restore iPhone 4S

Discussion in 'iPhone Tips, Help and Troubleshooting' started by j0hnj0hn, Mar 11, 2012.

  1. j0hnj0hn macrumors newbie

    Joined:
    Mar 11, 2012
    #1
    Hello!

    Yesterday, I attempted to install iOS 5.1 to my iPhone 4S but something went wrong and I got an error and the phone went into recovery mode. Upon trying to recover it, I get the following error during the "Restoring iPhone Firmware"-phase:

    "The iPhone "iPhone" could not be restored. An unknown error occurred (-1)."

    I can't find anything about the -1 error and I've tried to restore it about 10 times during the last 24 hours. Can anyone help me out?

    Thanks,
     
  2. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #2
    try putting it in DFU-mode and restore from there
     
  3. j0hnj0hn, Mar 11, 2012
    Last edited: Mar 11, 2012

    j0hnj0hn thread starter macrumors newbie

    Joined:
    Mar 11, 2012
    #3
    How would I do that? All the tutorials I've found requires me to keep the power cable plugged in, which I can't. With the cable plugged in, the iPhone is turned on and I cannot turn it off without it turning on again after a second. I've already attempted to do it despite this, but it won't work.

    EDIT: I think I managed to get it into DFU-mode but I still couldn't restore it. Do I have any options left other than leaving it in for repair?
     
  4. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #4
    did you try to kick it out of recovery with TinyUmbrella ?
     
  5. j0hnj0hn thread starter macrumors newbie

    Joined:
    Mar 11, 2012
    #5
    I just tried that and seem to have gotten it into an infinite loop. Upon turning it on (doesn't matter if it's connected to my computer or not) it loads something, then it looks like it's downloading something, then it loads and so forth. It's been the same for almost an hour without change. iTunes doesn't see the device when I plug it in either. I've tried rebooting it several times.
     
  6. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #6
    try putting it into DFU-mode again and ALT-restore(mac) or SHIFT-restore (Win) with a downloaded IPSW

    DFU mode your screen is blank, nothing shows

    Press home and power together, until screen turns blank, keep holding both another 3 seconds and than release power, holding home another 8 seconds, screen should be blank
     
  7. j0hnj0hn thread starter macrumors newbie

    Joined:
    Mar 11, 2012
    #7
    Thank you –*that worked. I got the phone back to the point where it gives me a -1 error when I try to restore from backup. It's currently in restore mode and there's just a few icons on the screen telling me to connect it to iTunes.
     

Share This Page