Error while installing OS X on new SSD or restoring with Time Machine

Discussion in 'MacBook Pro' started by xiug, Jul 13, 2015.

  1. xiug macrumors newbie

    Joined:
    Jul 13, 2015
    #1
    Hey,
    I have a problem installing OS X on a new SDD, which I build into my MacBook, or restoring a Time Machine backup on this SSD.
    Some background info:
    The HDD of my MacBook Pro (Mid 2010) broke and I decided this was the right moment to upgrade my MacBook and buy a SSD.
    So I bought a 500GB SSD (more than my old HDD) and put it in my MacBook at the same spot where the old HDD was. The SSD is detected by Disk Utility and acts totally normal when being accessed through Disk Utility. I can erase the SDD and create partitions (which I did several times), but I can not install OS X on it or restore my backup onto it.

    When I try to install the system, I receive an error saying: "The installation could not be completed. Please restart and try again." This occurs instantly (1 second) after the Installer asks for permission to download the new system and I click on Yes.
    When I try to restore my backup, the restoration process gets to around 20%, then it stops and shows the same error like the OS X installation does.

    I used my backup HDD, a recovery USB-stick and the recovery manager to install OS X but nothing worked.

    Does anyone know anything I could try to fix this problem?
    Thanks in advance.
     
  2. Bending Pixels macrumors 65816

    Joined:
    Jul 22, 2010
    #2
    Sounds like it's improperly formatted. Make sure that it's formatted for Mac OS Extended and under Options, choose GUID Partition Table.
     
  3. xiug thread starter macrumors newbie

    Joined:
    Jul 13, 2015
    #3
    Thanks for the reply, but I did that already.
    Did it again now to check, but the errors still come up.

    To be precise the error while trying to install the system reads:
    "An error occurred while preparing the installation. Try running this application again."
     

Share This Page