Error while upgrading to 4.2 now it is frozen and won't connect / start at all

Discussion in 'iPod touch' started by bhavbhuti, Nov 29, 2010.

  1. bhavbhuti macrumors newbie

    Joined:
    Nov 29, 2010
    #1
    Hi all

    The iPod Touch was being upgraded to the latest OS 4.2. The download of the OS had happened and now when the update button was clicked while connected to iTunes something went wrong and the upgrade process terminated in iTunes. Now the iPod Touch only shows the USB iTunes screen. All tries of resetting the unit doe not work and everytime when connecting the now dead iPod Touch's USB Windows Xp asks if i want to install the driver which it subsequently cannot find.

    What do I do now? Do I need to reset to factory defaults if so how do I do it?

    Please advise

    Kind regards
    Bhavbhuti
     
  2. texfire macrumors member

    Joined:
    Nov 8, 2007
    #2
    Perhaps I'm in your same boat and could use some assistance.
    I tried to upgrade software and I've been stuck at about 95% on the progress bar for the past hour...
    Any idea what the hangup is or how to resolve it?
     
  3. cougargb macrumors newbie

    Joined:
    Nov 30, 2010
    #3
    I had the same problem!

    Nothing I did on my PC, clear cache, cookies helped.

    I then connected my iPod to my Netbook (iTunes installed) and restored it to factory settings! This doesn't recover personal data saved!

    Then connected to PC and synced apps and contact data!

    Hey presto I have an iPod that works!

    Too scared to try upgrading to 4.2 again :eek:

    Hope this helps.

    Chris
     
  4. CubusX macrumors 6502

    Joined:
    Sep 9, 2009
    #4
    Try this...

    I had this problem with my iPhone 4 and a Mac. I had to uninstall and reinstall iTunes.

    They have the support article on their website. See if that works. Make sure you backup all of your iTunes library prior to doing this as a precaution.
     
  5. bhavbhuti thread starter macrumors newbie

    Joined:
    Nov 29, 2010
    #5
    Thanks all for the responses.

    @CubusX: I had tried all that I was able to find on their website. I finally made a support call and I was told to look for in the whole of Control Panel and see if I can find something related to Apple / iTune. In the System icon Device Manager I found there were two Apple Mobile Device Drivers which were flagged as ? with a tiny ! mark on it. So the rep. told me I needed to get the drivers from Microsoft, which was surprising because they were Apple drivers, but nevertheless I asked him if I could connect the iPod Touch on another PC and see if I can un-freeze it he said that was another option.

    So I attached to my PC after installing iTunes + Quicktime, it unfroze and iTunes then Restored it to original setting as well as downloaded 600+MB and updated the iPod Touch to 4.2.1

    Since then I was able to connect with the original PC with a fully uninstalled and installed iTunes + Quicktime. There were quirks but I believe that was operating issues (hopefully). Settled for now.

    Though I must say I never required to get the drivers from Microsoft after all :confused: So I don't think that was the original reason of the problem, or they are bundled with iTunes+Quicktime pack and were rectified on the reinstallation.

    Kind regards
    Bhavbhuti
     

Share This Page