Ethernet 2 (en1) is missing

Raunien

macrumors 6502
Original poster
Aug 3, 2011
438
28
Hello everyone,

I got home today and found my mac pro completely shut off. Not sure if the power went out when I was away or what happened. The machine wouldn't turn back on, but after unplugging the power and replugging it in, it booted. Everything seemed fine.

However, I noticed that my ethernet 2 port is not working. As in when I go into network utility, Ethernet 2 (en1) is missing. Ethernet 1 (en0) is still functioning.

Any ideas about what to do?

Thanks.

Mac Pro 2010, 10.11.6
 

Floris

macrumors 68020
Sep 7, 2007
2,381
1,451
Netherlands
Open terminal app and type ifconfig -va
Is it no longer listed there too?
maybe run ifconfig with parameters discover or learn (check man ifconfig for details) and then plug a cable in, maybe it kinda 'wakes it up'.
 

Raunien

macrumors 6502
Original poster
Aug 3, 2011
438
28
I ran ipconfig and it is not listed there.

It goes from en0, en2...
 

Raunien

macrumors 6502
Original poster
Aug 3, 2011
438
28
I guess that's my last option. I was hoping to avoid that as I have to replace the graphics card.
 

Floris

macrumors 68020
Sep 7, 2007
2,381
1,451
Netherlands
I guess that's my last option. I was hoping to avoid that as I have to replace the graphics card.
Just edited my above post, also, .. I am just throwing some stuff against the wall to try and see if your system can even see it. I hope some power cut didn't short the port or whatever..

Who knows, maybe someone else with more experience on this than me can post and get you in the right direction.
 

Raunien

macrumors 6502
Original poster
Aug 3, 2011
438
28
I'm running the AHT now. I have a hunch that the port is dead.

And the plot thickens...

Ran AHT and it turned out NO ERRORS FOUND. In addition, both ethernet's are recognized under hardware profile

http://imgur.com/a/YQ28L

UPDATE: All well now, reset NVRAM after AHT and it is now being recognized. Thanks @Floris !
 
Last edited:
  • Like
Reactions: Floris

Floris

macrumors 68020
Sep 7, 2007
2,381
1,451
Netherlands
Phew! I was reading up on resetting stuff, after writing on my blog about enable/disable SIP and I came back here hoping to figure out if it could help you any. Glad to read it is already resolved and that running diagnostics, resetting pram, smc, nvram etc might have simply helped out.