Ethernet cable not letting MBP sleep

Discussion in 'MacBook Pro' started by millerrh, Jun 11, 2007.

  1. millerrh macrumors 6502

    Joined:
    Sep 14, 2005
    #1
    I posted something about this last week, but I've narrowed down the problem, so I wanted to start a new thread.

    My problem was that my MacBook Pro would not fall asleep by itself using the Energy Saver settings. I can force it to fall asleep by using the :apple: menu however.

    At first I had no idea what could be causing it, but I started playing with configurations and figured out that when my home ethernet cable is hooked up to it, it causes the computer to not sleep. Using Airport or the ethernet cable in my office, it falls asleep fine.

    This is a new problem and I have not changed my router or cable modem.

    Anyone got any ideas what could be causing this?
     
  2. samh004 macrumors 68020

    samh004

    Joined:
    Mar 1, 2004
    Location:
    Australia
    #2
    Does the setting "Allow Ethernet to wake computer from sleep" or something along those lines have anything to do with it ?

    Perhaps the ethernet at your home is always sending a signal that the work one is not sending...
     
  3. Aniej macrumors 68000

    Aniej

    Joined:
    Oct 17, 2006
    #3
    this is very likely your answer. go into system prefs and energy, and then options and you will see where to uncheck.
     
  4. BurtonCCC macrumors 65816

    BurtonCCC

    Joined:
    May 2, 2005
    Location:
    Wheaton/Normal, IL
    #4
    I believe the exact option is "Wake when the modem detects a ring."

    Best of luck.

    Daniel.
     
  5. samh004 macrumors 68020

    samh004

    Joined:
    Mar 1, 2004
    Location:
    Australia
    #5
    Can't check on this peecee, sorry :(
     
  6. millerrh thread starter macrumors 6502

    Joined:
    Sep 14, 2005
    #6
    Actually, it is "Wake for Ethernet network administrator access" and unchecking that box didn't change the behavior. I think because mine never actually goes to sleep to allow anything to wake it.

    But I've got good news!

    Since I pretty much narrowed it down to my network somehow, I went and started messing with the router and modem. Turns out the router port my computer is on had blinking LEDs instead of the usual solid lights. I plugged it into a different port and it works now.

    Still don't know what is up with the router or how that could effect the sleeping behavior, but at least it is working now.
     
  7. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #7
    hhmm if that port was possibly dead then it might have been sending bad packets constantly to your computer..thus not allowing it to sleep?? maybe..
     

Share This Page