Ethernet Disconnects / reconnects after 2 seconds

Discussion in 'Mac Pro' started by Jigga Beef, Sep 13, 2018.

  1. Jigga Beef macrumors regular

    Joined:
    Jan 11, 2009
    Location:
    Philadelphia, Pa
    #1
    On my Mac Pro 5,1 I cannot get it to connect via the ethernet port. I am running high sierra,

    The cable works fine, has a constant connection on my macbook pro.

    I have tried
    Reset PVRAM
    Reset SMC
    Delete Network System Preferences
    Reset Router


    When the ethernet cable is plugged in it says unplugged, connects for about .5 seconds than goes back to saying nothing plugged in.

    I have tried both ports and its the same result.


    Anything else to try?
     
  2. Matty_TypeR macrumors regular

    Matty_TypeR

    Joined:
    Oct 1, 2016
    #2
    Have you run a hardware test to see if the ethernet ports report any problems?
     
  3. Jigga Beef thread starter macrumors regular

    Joined:
    Jan 11, 2009
    Location:
    Philadelphia, Pa
    #3
    I have not, Is there a guide on how to do that? (I'm sure there is I am just not sure what to search for.)
     
  4. bookemdano macrumors 65816

    Joined:
    Jul 29, 2011
    #4
    What is the cable plugging into? If an ethernet switch, try a different port in the switch (and power cycle the switch while you're at it).
     
  5. Jigga Beef thread starter macrumors regular

    Joined:
    Jan 11, 2009
    Location:
    Philadelphia, Pa
    #5
    Cable is plugged into a router. The same cable and same port work on my MacBook pro that's why I am thinking its specific to the mac pro.
     
  6. bookemdano macrumors 65816

    Joined:
    Jul 29, 2011
    #6
    Most routers have four or more ports. Even if yours are all filled, try to swap the cable into one of the other ports (and while you are at it, reboot the router).

    I have seen the behavior you describe before (not with the Mac Pro but with other computers). Sometimes on a marginal connection, one device can negotiate and another one plugged in to the exact same port with the same cable can't. The fact that it is happening with BOTH ethernet ports on the Mac Pro make it less likely that the hardware on the Mac Pro is at fault (because the two ports go to separate controllers on the logic board).

    Not saying that rebooting your router and trying a different port & cable will fix this, but there is a chance that it will. It's definitely worth trying.
     
  7. Jigga Beef thread starter macrumors regular

    Joined:
    Jan 11, 2009
    Location:
    Philadelphia, Pa
    #7
    I had 3 other things plugged in removed them all, moved the port I was using for this ethernet cord, reset the router, reset the computer and I am still having the same issue.

    Very odd.
     
  8. bookemdano macrumors 65816

    Joined:
    Jul 29, 2011
    #8
    Did you say you tried one of your other cables?

    Did you have the Mac Pro successfully connected before this problem started occurring? Or is this the first time you've ever connected it?

    One thing you can and should try, connect your MBP's ethernet port directly to one of the ethernet ports on your cMP. Does that result in a stable connection on the cMP or does it still toggle on and off?
     
  9. misanthrophy macrumors regular

    misanthrophy

    Joined:
    Aug 16, 2018
    #9
  10. Jigga Beef thread starter macrumors regular

    Joined:
    Jan 11, 2009
    Location:
    Philadelphia, Pa
    #10

    Yes

    When they are connected it shows a orange dot and says Self Assigned IP on both machines.
     
  11. bookemdano macrumors 65816

    Joined:
    Jul 29, 2011
    #11
    The self-assigned IPs are normal since there's no DHCP server in there handing out IPs. If the connection is stable then I think the ethernet ports in your Mac Pro are fine.

    Did you ever have the Mac Pro working with this router before?

    A router or switch that's underpowered might cause this. Do you have the means to test the "wall wart" power supply on your router? It's a common item to fail, and even though it appears to work fine now, it may get worse and crap out over time. If you have another power supply that has the same output voltage and amps specs then you can try to swap it out to see if it makes any difference.

    What model router is this? Does it have 100Mbps or 1000Mbps ports? It's possible that auto-negotiation is not working properly and you can try disabling it. In Network Preferences>Ethernet 1 (or 2, whichever one you're using)>Advanced>Hardware>Configure set it to Manually and try setting the speed to 100baseTX. Apply the change and then reconnect your cable and see if it's stable. If it is and if your router has gigabit ports then you can try setting the speed to 1000BaseT and hit apply and see if it's stable.
     
  12. verdejt macrumors 6502

    verdejt

    Joined:
    Jul 19, 2011
    Location:
    Central Florida
  13. Squuiid macrumors 65816

    Squuiid

    Joined:
    Oct 31, 2006
    #13
    This. Please state the router make and model and the firmware version it is running.
     
  14. Jigga Beef thread starter macrumors regular

    Joined:
    Jan 11, 2009
    Location:
    Philadelphia, Pa
    #14
    Router Info Model: TG1662G
    Vendor: Arris Group
    Hardware Revision: 11.0
     
  15. verdejt macrumors 6502

    verdejt

    Joined:
    Jul 19, 2011
    Location:
    Central Florida
    #15
    Are you using DHCP to automatically assign an address to your computer? If so try setting your MacPro to DHCP with Manual address and specify a hard address for your MacPro. I have had this in the past with other computer/devices and that is the setting I had to use. I have a ARRIS TG1682 that I use to connect to my Internet via cable.
     
  16. Squuiid macrumors 65816

    Squuiid

    Joined:
    Oct 31, 2006
    #16
  17. Jigga Beef thread starter macrumors regular

    Joined:
    Jan 11, 2009
    Location:
    Philadelphia, Pa
    #17
    Changing the network to
    100baseTX in Advanced seemed to work after an SMC Reset!

    Thanks everyone!
     
  18. bookemdano macrumors 65816

    Joined:
    Jul 29, 2011
    #18
    Glad you got it stabilized. Set a mental note that if someday you replace your router (and still have your cMP), set Ethernet back to auto-negotiate. That's where it's supposed to be and in 99.9% of cases it works fine on that setting. But it's likely any newer router you get will have gigabit ports and you won't be able to take advantage of that speed if you leave your Mac Pro manually set to 100megabits.
     
  19. Jigga Beef thread starter macrumors regular

    Joined:
    Jan 11, 2009
    Location:
    Philadelphia, Pa
    #19
    It acutally stopped working after about 2 minutes. I tired another SMC reset, didn't help having the same issue as before
     
  20. verdejt macrumors 6502

    verdejt

    Joined:
    Jul 19, 2011
    Location:
    Central Florida
    #20
    Try my suggestion and see what happens. It could be that the router doesn't see the MacPro to assign an address via DHCP. Try DHCP with manual address in your setting on your MacPro network settings.
     
  21. bookemdano macrumors 65816

    Joined:
    Jul 29, 2011
    #21
    A DHCP issue shouldn't cause the status to say Unplugged though. That implies an issue at the physical layer. Still worth a try I guess.

    OP, is your router provided by your ISP, or is it one you purchased? If the former, you may want to call them and see if they can swap it out. The fact that you connected your cMP successfully to your MBP without the connection dropping tells me that your ethernet ports are fine. It could be a failing power supply on your router or buggy/crappy firmware as Squuiid said.

    If you absolutely must keep your router, do you have, or can you buy or borrow an ethernet switch? You don't need anything fancy--a simple 4 or 5 port model will suffice. They can be had for less than $20 on amazon or best buy. You can plug that in between the router and your cMP--that may allow for a stable connection.

    You haven't said, but I assume you have tried another cable (even though the one you have works with your MBP). Do that first before you try anything else.
     
  22. Jigga Beef thread starter macrumors regular

    Joined:
    Jan 11, 2009
    Location:
    Philadelphia, Pa
    #22
    It seems to be working steady now but I am getting 50 MBS, where as from my MBP I was getting about 110 MBS while connected to the same port and the same cable.

    Does a cMP 5,1 have a slower ethernet port than I would get though Thunderbolt 2 to Ethernet on my MBP.
     
  23. bookemdano macrumors 65816

    Joined:
    Jul 29, 2011
    #23
    It's likely because you forced 100BaseTX on your Mac Pro's ethernet port. If your router has gigabit ports then you should try setting it to 1000BaseT.
     
  24. Jigga Beef thread starter macrumors regular

    Joined:
    Jan 11, 2009
    Location:
    Philadelphia, Pa
    #24

    So I got a new router from Xfinity and it fixed the issue as stated! Now it works automatically.

    Right now I am seeing Speeds of about 90 MBS on Ethernet hard wire / about 110 WiFi.

    Since the new router only has 2 ethernet ports I've bought an 8 port hub.

    https://www.amazon.com/gp/product/B00A121WN6/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1

    Question, should I book up the ethernet cable thats going from my computer into the powered hub or to directly into the router. I feel like I'll get more stable speeds directly into the router but wanted to check.
     
  25. verdejt macrumors 6502

    verdejt

    Joined:
    Jul 19, 2011
    Location:
    Central Florida
    #25
    I have my computer directly into my cable modem and everything else plugged into a switch. You really don't want to use a hub it will slow your traffic. You want to get a switch because the traffic is routed to the IP address it's intended for and no other computer, whereas a hub sends traffic to all computers connected to the hub. I know there is a better way to explain it but it's late and right now it's the best I can do. If someone can explain it better please feel free to jump in. :)
     

Share This Page

28 September 13, 2018