Ethernet has a self-assigned IP address and will not be able to connect to the Internet.

Discussion in 'macOS Sierra (10.12)' started by melbri, Nov 1, 2017.

  1. melbri macrumors member

    Joined:
    Sep 14, 2008
    #1
    My son was screwing around and disconnected all the ethernet cables from my switch. I have the feed coming from the wall to the switch and two cables going to a mini and an imac. Both have this "Ethernet has a self-assigned IP address and will not be able to connect to the Internet." Wifi is fine, and I can access my network drives. I have tried most of what I have found to troubleshoot the problem with no avail. The wifi on the imac no longer works so I need the ethernet.

    Any help would be appreciated. I am a noob when it comes to network jargon.

    I use Bell Aliant Home Hub 3000 as the modem.
     
  2. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    Just plugging it all back in the way it was should work. Is the switch plugged in? You may have to bypass it directly to one of the Macs to check the functionality of the switch.

    Try a restart of everything involved first.
     
  3. melbri thread starter macrumors member

    Joined:
    Sep 14, 2008
    #3
    Same thing with a by-pass and it was reconnected in the same manner, only three cables.

    The only thing I have not restarted is the modem, which I have to wait for morning to do as it feeds my PVR as well.

    What is the "self assigned IP" anyway? I don't understand what happened? Is it software or hardware?
     
  4. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    It’s just not getting an IP from the router. Usually it’s the connection but I’ve seen a router restart get things working when the connection is fine. If a modem restart fixes it you shouldn’t be concerned. The sudden disconnect probably confused the router firmware.
     
  5. melbri thread starter macrumors member

    Joined:
    Sep 14, 2008
    #5
    I have restarted the modem & mini several times, tried a new switch and new cables. The imac has come back, but my mini still shows a self assigned ip. When I select "Using DHCP with manual address" and plug in the mini's ip, ethernet goes green and says all is good, but does not connect to the internet. If I select "Using DHCP" it goes red and does nothing. My modem shows the mini as connected, even with the mini's wifi off. I can also connect to my network drives. It seems there is something wrong in os x.
     
  6. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #6
    I don’t recommend setting the IP in a Mac’s network preferences. A conflict can occur if your router gives that IP to another device while the Mac is disconnected or off.

    Does your router firmware have a “DHCP Reservations” (or similar). If so, try specifying an IP for your Macs there. The reservation is based on ethernet address so it can’t be the same for wifi as it is for ethernet.

    Sounds like you’re close, though, with the iMac working.
     
  7. melbri thread starter macrumors member

    Joined:
    Sep 14, 2008
    #7
    I do not see a DHCP Reservation, but there is IP Reservation. My imac ethernet and wifi have the same IP.
     
  8. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #8
    This is from my archives.
    I make no promises that it will work for you.
    It's a "wifi" solution, but try it anyway.
    ===================================================
    1. Turn off your wireless in your troubled Mac.

    2. Open System Preferences->Network tab and highlight your Airport card.

    3. In the right hand pane click on the 'Advanced' button.

    4. In the main 'Wi-Fi' mini-tab delete all 'Previous Networks' connections.

    5. The save out and then go to the application /Applications/Utilities/
    Keychain Access.app and in that application find the entries for your wireless router.

    6. Then go back into your System Preferences->Network pane and highlight your Wi-Fi card again and use the pane to turn on your wireless again and use that to rejoin your wireless network.

    7. Put in your username/password again and rejoin and save the password again.
     
  9. melbri thread starter macrumors member

    Joined:
    Sep 14, 2008
    #9
    Thanks for your help Brian.

    I did what you just asked, but I do not understand the connection to my ethernet problem.
    --- Post Merged, Nov 3, 2017 ---
    Sorry Fishrrman, I thought your post was BrianBaughn. See my previous post.
    --- Post Merged, Nov 3, 2017 ---
    Well.....I am connected again. I was fiddling around with my modem and was examining ethernet connections. There was an old "disconnected" PC connection that I selected "Forget" and then the mini highlighted and showed as connected. Went back to network prefs, turned wifi off and voila, ethernet internet is back. I have no idea what went wrong or have it corrected.
     
  10. Tech198 macrumors G5

    Joined:
    Mar 21, 2011
    Location:
    Australia, Perth
    #10
    Power down Mac, then power off modem first and back on, then power on the Mac
     

Share This Page

9 November 1, 2017