Ethernet not working on my Air

wunderbaren

macrumors member
Original poster
Mar 25, 2006
49
0
Stockholm, Sweden
I can't get ethernet to work on my new MacBook Air. I bought the USB Ethernet Adapter for MacBook Air, and it's plugged in, but still the ethernet wire doesn't seem to get any contact.

I can see the USB adapter in setting for network, so it seems to to be connecter with my Air.

THe other thing is that my friend bought himself a Laptop PC, and he used the SAME ethernet wire, and it worked right away.
 

SFStateStudent

macrumors 604
Aug 28, 2007
7,492
3
San Francisco California, USA
My MBA ethernet adapter has been working without incident. Do you find that there's too much play in your adapter? Does it wiggle around? I had another USB 2.0 plug that seemed to have too much play and it didn't work until I replaced the USB 2.0 cable for the device. :(
 

wunderbaren

macrumors member
Original poster
Mar 25, 2006
49
0
Stockholm, Sweden
more information required
MacBook Air 1,6 GHz Intel Core 2 Duo
2 GB 667 MHz

Leopard 10.5.4.

The adapter is showing as "Apple USB Ethernet Adapter" if you go to "system information", but if you go to network preferences, the "dot" is red, and is telling me that the adapter isn't plugged in?
 

SFStateStudent

macrumors 604
Aug 28, 2007
7,492
3
San Francisco California, USA
The adapter is showing as "Apple USB Ethernet Adapter" if you go to "system information", but if you go to network preferences, the "dot" is red, and is telling me that the adapter isn't plugged in?
That's why you may want to check your USB 2.0 port to ensure it's not the MBA USB port. Connect another USB device into your MBA USB port. Try using another ethernet cable as well.
 

SFStateStudent

macrumors 604
Aug 28, 2007
7,492
3
San Francisco California, USA
Sorry to hear that. I just double-checked my Ethernet Adapter and it's up and running. I ran the Ethernet cable at the same time as my WiFi and checked Network Preferences and they both showed up with the green dot. I disconnected WiFi and Ethernet Connection still had the green dot and connected WiFi and disconnected the Ethernet Connection and still had a green dot for WiFi. Keep us posted on the replacement Ethernet Adapter...:(
 

wunderbaren

macrumors member
Original poster
Mar 25, 2006
49
0
Stockholm, Sweden
When i brought the Adapter to the store they tested it in another AIr, and it worked perfect :(

So they didn't allow me to change it, so when i got home, i erased the computer and made a fresh install, and then it worked again, but id doesnt work now :(
I'm going back to the store with the Air again today..
 

SFStateStudent

macrumors 604
Aug 28, 2007
7,492
3
San Francisco California, USA
I will go ot store in about 3 hours and check with them. My mouse, my superdrive, everything works exept this thing!!
My USB 2.0 port seems to work sometimes with one device, so I removed the USB cord from the device and replaced it and now it works fine. There just seems to be a certain amount of "wiggle" with my USB port, so I might get that checked tomorrow. Good luck tomorrow, keep us advised...:cool: