Ethernet not working on Yosemite

Discussion in 'Mac Basics and Help' started by Olbert000, Mar 6, 2015.

  1. Olbert000 macrumors newbie

    Joined:
    Feb 7, 2011
    #1
    My ethernet cable internet has stopped working.

    I normally connect my 2013 MBP to the internet via my home wifi network, however I often like faster internet for downloads, games, etc and connect using an ethernet cable and a thunderbolt adapter. It has stopped working. Normally I have to turn off the wifi to force it to use the ethernet (not sure why!?) but that makes it work. This time that doesn't work and diagnostic/assistant doesn't help either.

    The wifi works on the same network. The ethernet cable and port works on a different laptop (I haven't checked the thunderbolt adaptor because it's not a mac).

    Why would it stop working (I haven't changed anything)? How can I fix it?
     
  2. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    Simple question (perhaps you've already done it), but...

    ... have you tried rebooting the MacBook?
     
  3. Olbert000 thread starter macrumors newbie

    Joined:
    Feb 7, 2011
    #3
    Yes - I've tried rebooting it.

    Interestingly the last time it worked was when I was on Bootcamped Windows 7. Could that have messed with any settings?
     
  4. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #4
    Are you using the Apple GigE Thunderbolt adapter or a 3rd party?
     
  5. Olbert000 thread starter macrumors newbie

    Joined:
    Feb 7, 2011
    #5
    Apple one.
     

Share This Page