ethernet port difficulty

Discussion in 'MacBook Pro' started by willauqs, Mar 18, 2011.

  1. willauqs, Mar 18, 2011
    Last edited: Mar 18, 2011

    willauqs macrumors newbie

    Joined:
    May 21, 2008
    #1
    Hey guys,

    I'm currently unable to connect to the internet through the ethernet port on my MBP at work and heres what i know:

    - I just had the logic board replaced, so i thought there might be an issue with the new port.

    - BUT, the ethernet port works fine if i bootcamp into windows. It is only an issue on OSX so im assuming its not a hardware issue with the computer or internet.

    - Wireless worked last night at home but I don't have wireless at work, so I can't confirm that it's still fine.

    - If i go into System Preferences > Network it recognizes when i plug in the Ethernet cord.

    - if i try to use Safari it loads like 10% and stays at a white screen. i can't get the internet with any other applications in osx either.

    -*ALSO* I just did a diagnostics test for my ethernet connection and it said everything is working correctly. but no internet pages will load! =/


    Does anyone know how to address this issue?? Thanks so much.

    Will
     
  2. Mik3F macrumors 6502

    Joined:
    Feb 3, 2011
    #2
    You haven't told it to use a proxy server by mistake have you?

    Long shot I know
     
  3. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #3
    It recognizes a cord plugged in, but does it get an address from the companies dhcp server (should say what it is when connected? You haven't changed a setting to usual manual addressing instead of dhcp have you? Also, does your company use mac addressing for recognition, because if so, the mac address changed with the logic board change and the new mac will need to be added to their system? These ideas are just a few of the possibilities that would make a valid port not be able to access a network. We need more information and specifics as to what you have tried and the exact results, such as no addressing assigned or a certain address assigned, ect.
     

Share This Page