Ethernet problem. Storm?

Discussion in 'Mac Basics and Help' started by BabyApple, Jul 25, 2006.

  1. BabyApple macrumors newbie

    Jul 25, 2006
    a couple days ago we had a storm, nothing too major, and I don't even know if that has anything to do with this, but our power went out a few times, for about 5 seconds each. I have a surge protector on my computer.

    well when i turned on my computert the next day. my interent didn't work. and now it says that i am not hooked up to the internet. I tried unplugging the ethernet cords and using different ports on that box thing, I think its called the router.(sorry I don't know the terminology) and still nothing. However my moms computer (windows) is hooked up to the same router and her internet works fine.

    I was thinking that it could be the cord? its really long and kinda old and its all tangled in a few places.

    I'm going to replace the cord...but if that doesn't work what should I do? I've being reading about fried ethernet. Any suggestions?
  2. jsw Moderator emeritus


    Mar 16, 2004
    Andover, MA
    If you can get a new cord and plug it into the port your mom is currently using, you could verify that at least that port works with your Mac. You might even want to try this with your current cable. Likewise, try plugging your mom's cable into where yours is currently plugged in and see if that works. If it does, then it's almost undoubtedly the cable, although it's possible you somehow messed up your network settings.

    If you go to System Preferences...->Network->"Show: Network Status", does it say the Ethernet port is currently active?
  3. Fleetwood Mac macrumors 65816

    Fleetwood Mac

    Apr 27, 2006
    A couple things to try;

    Restart the box (yes, its called a router) and for good measure, the cable/dsl browser as well (if you have one)-I'm assuming you've already restarted your Mac.

    If that doesn't help at all you can open the Network Utility under Utilities in the Applications folder.

    If not selected, although it probably will be when you start up the program, select NI (en0)-that's ethernet. This is all under the info tab by the way. If the [IP] address is something like then you might have a deeper problem that would require more thourough diagnostics, but if its something then its probably a matter of just a bad connection/cable as you suggested. Worst case, your ethernet card is not functional and won't show up in the Network Utility, but I think that this scenario is quite unlikely.
  4. Fearless Leader macrumors 68020

    Mar 21, 2006
    recently we had a storm and it fried three computers (i thought it was surge protector :( ) and a cable modem but only the ethernet jack.
  5. BabyApple thread starter macrumors newbie

    Jul 25, 2006

    I tried using a new ethernet cable...didn't work. I restarted the box...didn't work. Switched all the cords around to different ports..didn't work. when I went to System Preferences...->Network->"Show: Network Status it didn't show ethernet. It only said that airport and the internal modem were inactive. I played around a little and it tried to connect to PPP ethernet. but failed to.

    so any suggestions on what to do next? Should I call Apple, or comcast? Do I need to repair or replace something?

    thanks for the advice frustrating
  6. ChrisBrightwell macrumors 68020


    Apr 5, 2004
    Huntsville, AL
  7. rglatter macrumors regular

    Jul 24, 2006
    lol chris...

    I had this same problem with my internet after a storm. I was freaking out because my ethernet is run across my whole house up through the atic..anyways..waht I did to fix it was my cable modem needed to be restarted. im not sure if you tried that but it might help. If that dosent work im not sure if you have tried this or not but you said your moms computers internet was working unplug the network cable out of the back of that computer and plug it into the ethernet port on your mac. if that dosent work I would call apple and tell them of your situation. They should be able to give you suggestions and tell you what to do.
  8. catriona macrumors newbie

    Aug 2, 2006
    Ethernet Problem. Storm?

    I had an almost identical situation with my ethernet connection after a storm except I can see the ethernet - en0 with a an IP of (is that significant? ) in the network utility but when I try to connect (using PPPoE as per ISP) the network status shows "cable not connected" - while it actually is. Setup works fine with a PC. SO - port is "blown"? What to do now? No Mac specialists near me. Wonder how you got on with your machine - did Mac shop give you any advice?
  9. matticus008 macrumors 68040


    Jan 16, 2005
    Bay Area, CA
    Sounds like a blown network card/port at this point. If your built-in ethernet isn't showing up as existing at all, it's toast. If you've got AppleCare, give them a call, but I don't know whether it's covered. Check your surge protector warranty; if you've got a nice one, you might be covered wherever the router was plugged in (since the surge came through the router from the wall or the modem, depending on your setup). There's a pretty high chance you're SOL--I lost three PCI modems and one PC power supply in a single year when I lived in the Midwest many years ago, all of which I had to replace myself.

    Usually, you'd expect a fried DSL/cable modem from a line surge along that path, but I suppose it's possible that the modem and the router both survived and your computer served as a ground in the surge, receiving all the damage.

    The solution would be to pay to replace the built-in ethernet if it's not covered (expensive) or to buy a USB ethernet adapter (cheap) to reconnect to the Internet. I would also suggest surge protection for your DSL or cable connection using a quality surge protector.
  10. catriona macrumors newbie

    Aug 2, 2006
    Ethernet Problem. Storm?

    It'll probably be the USB ethernet adapter as you suggest , once the patient has had the "once over" by Mac knowledgable friend.
    Well at least now I won't drive it for 2 hours to find all it required was some really simple thing I should have done.

    Out of curiosity, using Network Utility, notice IP addresses for en0 and fw0 are the same - both when disconnected (now shows and when attempting to connect ethernet ( The aforementioned 159.134.205.etc occurs when the modem is running. Is this usual? The hardware addresses are different (fw0 being much longer than en0).


Share This Page