Ethernet slow boot

Discussion in 'iMac' started by Carlos840, Mar 23, 2015.

  1. Carlos840 macrumors member

    Joined:
    Nov 5, 2013
    #1
    Hi all,

    So, i am having a weird issue, i recently drilled my wall and got an Ethernet cable (cat 6E) from my router to my iMac (late 2014, i7, 512gb ssd, 16gb ram, running 10.9.5), i then added a Western Digital My cloud EX2.
    Everything is running great, nothing to complain about, apart from boot time.

    If i remove the Ethernet cable, and set the service order to WIFI first, Ethernet second and boot, i boot in around 10 seconds, which is normal.

    If i plug the Ethernet cable, and switch the service order to Ethernet first, WIFI second, i boot in around 3.5 minutes!!!

    Any thoughts? What could be creating this?
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    I wonder if it is searching the network to try a netboot. Look in System Prefs in the Startup Disk pane and make sure the correct disk is selected as the startup disk and it should stop that searching around for other boot devices.
     
  3. drsox macrumors 65816

    drsox

    Joined:
    Apr 29, 2011
    Location:
    Xhystos
    #3
    Did you restart everything in the order : Router - iMac - My Cloud ?
    i.e. turn all off and then turn on in that order. Maybe you have some old settings hanging around.

    What happens if WiFi is removed from your Network Settings ?
     
  4. Carlos840, Mar 23, 2015
    Last edited: Mar 23, 2015

    Carlos840 thread starter macrumors member

    Joined:
    Nov 5, 2013
    #4
    The only disk i see there is the internal Macintosh HD with os X.

    ----------

    I have rebooted everythign in every possible order and it makes no difference!

    I have just tried turning the WIFI off and rebooting, and it boots normaly, 10 seconds or less...

    Ethernet on its own, fast.
    WIFI on its own, fast.

    Both at the same time, 3.5 minute boot!

    ----------

    Well, this is embarassing!

    After rebooting with the WIFI off in network preferences i tried turning it back on and setting the service order back to Ethernet first, WIFI second, guess what?
    It worked and booted in 10 seconds!

    I don't understand! I rebooted at least 5 times, tried resetting the pram, smc, rebooted the router, the cloud, everything.

    Turning the WIFI off, rebooting, then back on again fixed it.

    Weird, but thank you anyway!
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    As it should be... but is that volume highlighted to show it is selected?

    Sounds like you got it sorted, but still worth a check.
     

Share This Page