iPhone evasi0n 1.0.7 issue

LaynieGorilla

macrumors 6502
Original poster
Jan 1, 2011
473
27
PA
Do I have to restore and rejailbreak to get evasion 1.0.7 or do I can I install this update overtop of 1.0.6?
 

dhlizard

macrumors G4
Mar 16, 2009
10,213
118
The Jailbreak Community
You should never re-jailbreak over an existing jailbreak except to perhaps add an untether (not the case here)

If you are having the Cydia bundles issue, you need to restore then re-jailbreak with newer evasi0n or wait for the newest evasi0n package to be added as a standalone update in Cydia.

If you are not having the Cydia bundles issue, you do not need to do anything.
 

bkribbs

macrumors 65816
Jan 15, 2012
1,178
0
You should never re-jailbreak over an existing jailbreak except to perhaps add an untether (not the case here)

If you are having the Cydia bundles issue, you need to restore then re-jailbreak with newer evasi0n or wait for the newest evasi0n package to be added as a standalone update in Cydia.

If you are not having the Cydia bundles issue, you do not need to do anything.
Why not? I always thought it was ok to do.
 

GreenMonster13

macrumors newbie
Apr 6, 2012
28
0
I just jailbroke w/1.0.6 tonight... and was having the caching issue. Older version of cydia substrate was showing up.

ipad mini is done, and I'm finishing up the iphone now.

Fixed it (temporarily?) by clearing cydia caches using iCleaner. Hopefully I won't have re-jailbreak using 1.0.7 and re-restore . UGH.
 

darricksailo

macrumors 601
Dec 18, 2012
4,354
113
Why not? I always thought it was ok to do.
it's not okay to do it

but people are willing to do it if it's the last thing they can try before they have to DFU restore to stock and wait for the next jailbreak, which could be in a few months
 

LaynieGorilla

macrumors 6502
Original poster
Jan 1, 2011
473
27
PA
Oh rats lol.. I have the problem but I just restored as new about a week ago. Thanks anyway!
 

dhlizard

macrumors G4
Mar 16, 2009
10,213
118
The Jailbreak Community

orytek

macrumors newbie
Jan 20, 2008
19
1
OpenBackup is awesome. I use it always when upgrading.

However you don't need to rejailbreak to fix the Cydia issue.
Just install iCleaner, turn off all options except Cydia Sources, and tap Clean. After process is complete, respring and return to Cydia and select Changes. Then select refresh at the top.
 
Last edited:

wacky4alanis

macrumors 6502a
Mar 18, 2009
541
70
So I did the fix with iCleaner once, am I good to go, or will I still need to re-jailbreak for it to work properly in the future?
 

orytek

macrumors newbie
Jan 20, 2008
19
1
That's it. Your done. Evasion 1.0.7 was only for fixing bundled repository package information, and iCleaner does it also by deleting the necessary files.

As long as your updated to IOS 7.0.6 which includes important security fixes, your good.
 

LaynieGorilla

macrumors 6502
Original poster
Jan 1, 2011
473
27
PA
OpenBackup is awesome. I use it always when upgrading.

However you don't need to rejailbreak to fix the Cydia issue.
Just install iCleaner, turn off all options except Cydia Sources, and tap Clean. After process is complete, respring and return to Cydia and select Changes. Then select refresh at the top.
I tried this and it didn't work. I still can't add modmyi back (which I took off because they told me I have too many sources or something) and my 'sections' list is empty. Might be best to hurry and restore before 7.1 arrives.
 

darricksailo

macrumors 601
Dec 18, 2012
4,354
113
I tried this and it didn't work. I still can't add modmyi back (which I took off because they told me I have too many sources or something) and my 'sections' list is empty. Might be best to hurry and restore before 7.1 arrives.
try adding modmyi under the "more package sources" in the cydia tab, if it shows up there

if the error still shows up, then that means you still have too many sources added
 

LaynieGorilla

macrumors 6502
Original poster
Jan 1, 2011
473
27
PA
try adding modmyi under the "more package sources" in the cydia tab, if it shows up there

if the error still shows up, then that means you still have too many sources added
I already did the more package sources thing, it still wouldn't install.

these are my sources, and this is after deleting about two or 3 of them

-bigboss

-

-cydia/telesphoreo

-

-zodttd & macciti

Are these really too much? Most of these except one are the ones that came with the jailbreak.
 
Last edited:

darricksailo

macrumors 601
Dec 18, 2012
4,354
113
I already did the more package sources thing, it still wouldn't install.

these are my sources, and this is after deleting about two or 3 of them

-bigboss

-(sensored)

-cydia/telesphoreo

-(sensored) repository

-zodttd & macciti

Are these really too much? Most of these except one are the ones that came with the jailbreak.
yes, it is too much

two of those listed (the ones you added) are related to piracy

you have to consider each piracy repo contains as much package as the default repos. so you basically have 3x the size of the default repos

the piracy repos are the ones you have to delete, not the default repos