Ever since tethering hack Iphone doesnt use 3g internet

Discussion in 'Jailbreaks and iOS Hacks' started by Cali3350, Nov 9, 2009.

  1. Cali3350 macrumors regular

    Joined:
    Feb 16, 2009
    #1
    Hey guys, hoping someone here can help me out with a problem I cant seem to figure out.

    Unlocked my Iphone using Blackra1n and then used the Cydia app to unlock tethering on my 3GS. Ever since my Iphone refuses to use its 3g internet connection most of the time. If i reset network settings it will work for a few hours before messing up again. Tried installing the custom BenM file to see if that fixes issue - it does not.

    Essentially the phone doesn't think it has a signal. Trying to use the internet in any application gives me the same error message - make sure your iphone isn't in airplane mode. It most certainly isn't.

    I love tethering but not being able to use apps and such make the hack not worth it. Anyone have this problem or know a solution? I might just do a restore back to stock and see if that helps.

    Appreciate any ideas you people may have on what the issue is :)
     
  2. jman240 macrumors 6502a

    Joined:
    May 26, 2009
    #2
    Settings -> General -> Reset -> Reset Network Settings.

    Reboot.
    All should be well (AT&T tested only)
     
  3. Cali3350 thread starter macrumors regular

    Joined:
    Feb 16, 2009
    #3
    Thanks for the reply. That does indeed fix it however it messes up again after around an hour. Something has to be messing p the phone as it goes.
     
  4. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #4
    It sounds like it could be a SIM card problem. Ask for a replacement SIM from your carrier and try that.
     

Share This Page