EVERY time I download/update an app my phone freezes without fail

Discussion in 'iOS Apps' started by Mike2128, Jul 21, 2008.

  1. Mike2128 macrumors 6502

    Joined:
    Mar 8, 2008
    #1
    :( I've restored 5 times already and it works fine to a point. Without changing my apps I have no problems. Anyone else seeing this?
     
  2. sanPietro98 macrumors 6502a

    sanPietro98

    Joined:
    May 30, 2008
    Location:
    28.416834,-81.581214
    #2
    Did you wait for the App to finish downloading?

    (I'm guessing that) because the iPhone does not allow background processes, I find that other apps (including Mail, Settings, Safari, etc) do not respond until the download/installation completes. Even if I tap the Settings icon while downloading an App, I get a blank screen until the installation completes.

    As soon as it does, the phone returns to normal for me.
     
  3. mavis macrumors 68040

    mavis

    Joined:
    Jul 30, 2007
    Location:
    Tokyo, Japan
    #3
    Five restores? I wish!! I've restored mine 21 times since July 11th. That's right, TWENTY-ONE.

    Three of those were caused by trying to restore from a backup (which failed all three times, requiring an immediate follow-up restore) but the other 18 were all caused either by installing/removing/updating apps, or interrupting the syncing process. My suggestion is to just let it do its thing, no matter how long it takes (updating Enigmo today, for example, took about five minutes - and that was the only thing I did on that particular sync) ... Also, if you see the activity indicator spinning (next to the 3G/wifi indicator) don't even think about touching the phone, unless you really want to make it freeze again.

    I hope Apple fixes this soon. I don't know about you, but I think 21 restores in less than two weeks is a bit excessive. ;)
     
  4. gadgetdad macrumors 6502a

    gadgetdad

    Joined:
    Sep 10, 2007
    Location:
    On my iPhone
    #4

    Yep, very disappointed in the 2.0 software. Never had this issue with my last jailbroken phone. It sucks that the official software is worst than the hacked software. :D
     
  5. ejrizo macrumors 6502

    ejrizo

    Joined:
    Jun 26, 2007
    Location:
    Los Angeles
    #5
    i have had the same thing happen to me plenty of times.... but even worse!

    that has happen to me twice now and it wont reboot... just stays stuck at the apple screen.... really annoying since i now have had to restore it for the second time... right now i just finished restoring and before i did anything with the phone i went to "Reset all content and settings" or whatever and told me it could take an hour or so and it sure is taking forever.... but i have a feeling that old files from the Jailbreak days are still around and making my phone bug out..... so setting it up as a new phone no syncs or backups from previous phones and resetting all content and settings...

    hopefully clears everything up and i can just sync and set up all my settings again once everything is erased.

    this whole adding apps from your phone has not beed a good experience for me... i think i am going to stick to adding apps through itunes from now on until a couple of software updates come along to get rid of all the bugs.
     
  6. mavis macrumors 68040

    mavis

    Joined:
    Jul 30, 2007
    Location:
    Tokyo, Japan
    #6
    Stuck at Apple logo - yup, been there, done that - I'm now starting my twenty-second restore. At least it worked this morning - that was kinda nice. :rolleyes:

    Well, the three times I've tried restoring from backups (three different backups, mind you) the phone has failed to boot (hangs at the Apple logo after the restore) so setting it up as a new phone seems to be the ONLY way to get it to work.


    I gave up on adding apps from the phone about a week and a half ago - but adding through iTunes doesn't seem to be helping much, in my case. ;)
     

Share This Page