Every USB fails to work properly

Discussion in 'Mac Basics and Help' started by MitchAustralia, Oct 6, 2012.

  1. MitchAustralia macrumors newbie

    MitchAustralia

    Joined:
    Oct 6, 2012
    #1
    Hey guys, I am new to this forum :)

    I have a had a problem occuring for a long time now, and I have searched high and low for answers, including on this forum, for a solution to this issue.

    It began with one USB that continued to eject itself on my iMac, and reappearing again in finder with the error box saying "the disk was not ejected properly etc".

    I tried other USBs and they all seem to do the same thing.

    Just today, dad brought home a relatively new USB with his files on it, so it clearly works on his MacBook Pro. The exact same happened..

    Any help would be much appreciated, cheers!
     
  2. quasinormal macrumors 6502a

    Joined:
    Oct 26, 2007
    Location:
    Sydney, Australia.
  3. MitchAustralia thread starter macrumors newbie

    MitchAustralia

    Joined:
    Oct 6, 2012
    #3
    By USB I meant thumb sticks, not external hard drives if that's what you're implying?

    I do have a 1TB Maxtor external hard drive which seems to work fine and is formatted to Tuxera NTFS; I had to purchase the Tuxera software in order for the drive to work fine on my Mac..

    The external drive has never randomly ejected itself, like the USBs do..

    Also, I have tried every USB port and they all seem to behave the same.
     
  4. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #4
    Well, since USB is just the bus, to which many different kinds of devices can connect, I don't know what other conclusion we were expected to draw. I also assumed you meant "hard drive", so now that you've identified the USB device as a flash drive, we can narrow down possible problems.

    1. Exactly which Mac model do you have? Which OS version?

    2. Exactly which USB thumb drive (model, capacity) was the one last tested, where it worked on your dad's machine but not on yours?

    3. Exactly which model of MacBook Pro did the USB thumb drive work on? Which OS version?


    Is that USB hard drive powered from the USB port, or does it have it's own power supply?


    Please do not call a USB thumb drive by the unqualified term "the USB". Please call it a thumb drive or thumb stick.

    Does that mean the thumb drives always fail, and the Maxtor hard drive always works? Or just that the thumb drives always fail?

    Do you have any other USB devices, such as keyboard, mice, trackpads, graphics tablets, iOS devices, SD card adapters, speakers, mics, headsets, etc.? Please provide as complete a list as possible.

    I'm asking about other USB devices because different devices draw different amounts of current. If the thumb drive is somehow drawing too much current, and one of the other devices you have draws a similar amount of current, then you can try that device and see if it also fails.

    Do you have any externally powered USB hubs attached to your Mac? If not, do you have one available you can use?
     
  5. MitchAustralia, Oct 6, 2012
    Last edited: Oct 6, 2012

    MitchAustralia thread starter macrumors newbie

    MitchAustralia

    Joined:
    Oct 6, 2012
    #5
    21.5 inch iMac, mid 2010. Latest OS; 10.8.2

    It was a SanDisk Cruzer 4GB.

    Not sure of the exact model, it is a 15 inch and he bought it a year or two before my iMac. Same OS as my iMac, 10.8.2

    It has it's own power supply.

    I apologise, sorry for causing confusion!

    Yes, as of yet the Maxtor hard drive has never failed. The thumb drives will last different amount of time before ejecting itself and the error message appearing. For example, last night I was copying a 1GB movie onto the SanDisk Cruzer as mentioned above, and it did allow me to complete the file transfer. However, upon ejecting it myself, it will bring up the dialog box saying that it is attempting to eject the drive, giving options of Force Eject or cancel from memory. This also happened on my dad's MacBook Pro when I gave him the movie.

    The only other items using the USB ports are a charging cable for my HTC phone, which has always worked fine with charging, as well as transferring files, and the apple charge/sync cable for connecting my iPod Touch 4th Gen. Always worked fine with no issues.

    I don't have one currently attached, however I have used one previously that I bought from Jaycar and still have it here with me, but from memory I stopped using it as it was playing up. Should I plug it in and give it a go? Here's a picture of it:

    [​IMG]

    Your help is much appreciated :)

    EDIT: I have MacFuse (Tuxera) installed, and have read that there may be issues associated with this? Soon I will be getting a new external hard drive to replace the Maxtor 1TB which is requiring this software, probably a Western Digital My Book for Mac.
     
  6. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #6
    Your iMac should have more than enough power on its USB ports.

    When the thumb drive is misbehaving, what else is plugged into the USB ports at the same time? If it's anything other than a keyboard and mouse, try disconnecting everything else, then try the thumb drive. So: keyboard + mouse + thumb drive; everything else completely unplugged.

    Also, if your keyboard has a supplementary USB port, make sure you DON'T plug the thumb drive into that. Only plug it directly into the iMac's USB port.

    The SanDisk Cruzer models don't have excessive current draws. I have 2 GB & 8 GB models, and they've always worked fine.


    It's conceivable that Tuxera is causing the problem, but I haven't heard of that problem before. The only suggestion I have there is to make sure it's the latest version from the vendor.


    I can't tell from the picture whether your external USB hub is externally powered or not. If it is, there would be a separate wall-wart transformer or power supply. I can't tell what the cable off the left side is; it could be USB or it could be power. Please clarify.


    Here's something else to try:
    http://support.apple.com/kb/HT1564
    http://support.apple.com/kb/HT1455

    Safe boot (Safe mode) is a way to temporarily disable extensions. This should be a simple way to test of Tuxera is causing trouble. If you boot in Safe mode, plug in the thumb drive, and it works consistently, then Tuxera could well be the problem.

    Something I don't know is whether Safe mode would prevent the USB thumb drive from mounting at all. If it's formatted as NTFS, then the lack of Tuxera will make the thumb drive unmountable. However, even if the thumb drive is formatted as HFS+ or exFAT, it still might not mount, because Safe mode might not load some of the extensions for mounting USB mass-storage devices.

    In any case, Safe mode is a simple thing to try, and if the thumb drive works, then it really narrows down the possible causes.
     
  7. MitchAustralia thread starter macrumors newbie

    MitchAustralia

    Joined:
    Oct 6, 2012
    #7
    My iPod charging cable as well as the Maxtor external hard drive are basically permanently plugged in. On occasion, I would have a WD external portable hard drive which I use to back up on a weekly basis, however this would only ever be in for an hour or so. I forgot to mention that I use both the apple wireless keyboard and the magic mouse. I will give that a shot next time I try to use thumb sticks.

    EDIT: Just removed everything from the iMac's USB ports, including my external hard drive. Problem still occurs on the thumb stick.

    Yep, briefly looked for a "check for updates" button or something similar the other day but was unsuccessful, I will ensure that I have the latest version some way or another.

    It is powered, using it currently and works fine, however the same problem occurred when inserting the Cruzer. Would this suggests that the problem has nothing to do with the ports in the iMac?

    That's a good idea, I will give that a shot and get back to you.
    Currently all of my thumb drives are formatted as FAT32, which I did a while ago through Disk Utility. We will see if safe mode mounts them.

    Thanks again.
     
  8. MitchAustralia thread starter macrumors newbie

    MitchAustralia

    Joined:
    Oct 6, 2012
    #8
    I am currently in safe mode, and straight away every thumb drive I inserted mounted fine, and did not eject randomly.

    To confirm that the Tuxera software was not running, I inserted the external hard drive, which theoretically could not be read a wrote to without Tuxera. However if functioned perfectly, suggesting that Tuxera is still running?

    Since this, the thumb sticks are continuing to play-up, even after uninstalling MacFuse and Tuxera NTFS. I know that seems radical but I have the serial number and can reinstall either at a later time.

    I am frustrated seeing as the problem is still occurring with a completely clean system. :confused:
     
  9. justperry, Oct 7, 2012
    Last edited: Oct 7, 2012

    justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #9

    I just want to chime in.
    In safe mode all worked well until you inserted the external drive?

    If this is right then the software starts up as soon as you insert the drive.

    NTFS can still be read with OOTB OS X, but not write AFAIK.

    I found a link to enable R/W access on NTFS without any software, thing is it is on 10.6, might still work on 10.8.2

    LINK

    Edit: Read the first few comments, there might be problems.

    Edit again: Saw you use Macfuse, I had before as well but I think the newer is OSXFuse, I have that one on My Mac.
     
  10. MitchAustralia thread starter macrumors newbie

    MitchAustralia

    Joined:
    Oct 6, 2012
    #10
    Yes, that's what I initially thought, however I shut down and booted up normally, then shut down again and booted into safe mode to test it once more. With no other devices inserted, all of the thumb drives played up again. So it doesn't appear as though the external hard drive or the software associated with it is causing the problem.

    I'll have a go at that link you referenced :)

    I was actually a bit confused as to what purpose MacFuse had? A while ago I used VMWare to setup parallels, and I thought that's where MacFuse had come from. It is uninstalled now, as well as Tuxera NTFS, and I can't delete or paste files from/to the external hard drive which suggests I have no writing permissions? I will reinstall Tuxera to ensure it is the latest version and see whether the problems are still present then.

    Cheers.
     
  11. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #11
    Yes, normally OS X does not give you R/W access out of the box so you can't do anything with it except reading.

    Oh, and 10.8.2 seems to have quite a few bugs last few days, that also may be the problem.
     
  12. MitchAustralia, Oct 7, 2012
    Last edited: Oct 7, 2012

    MitchAustralia thread starter macrumors newbie

    MitchAustralia

    Joined:
    Oct 6, 2012
    #12
    Yeah, just restarted after a OS update which was about 800MB.

    Things are still sh**ty, Finder is not responding, getting the lovely coloured spin wheel everywhere. Quite angry at the moment, might leave it for now until tomorrow (I'm Australian by the way).
     
  13. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #13
    It's just plain ridiculous that after so many years both Apple an Microsoft don't make decent drivers for mounting disks in R/W on both platforms, is it so hard to set aside the differences they have.
    Microsoft is the worst one, no HFS+ support at all, but at least there is software available which does just that and never had problems with it(MacDrive).
    At least we can read both Fat and NTFS on a mac.
     
  14. MitchAustralia thread starter macrumors newbie

    MitchAustralia

    Joined:
    Oct 6, 2012
    #14
    I agree, not fair on us consumers :(

    Maybe once I buy this new external drive and uninstall Tuxera things might improve..
     
  15. MitchAustralia thread starter macrumors newbie

    MitchAustralia

    Joined:
    Oct 6, 2012
    #15
    Help me right now my computer is dead. It will not turn on.

    EDIT: False alarm, ****ing power board isn't working or something. I want to go to sleep :(
     
  16. glutenenvy macrumors regular

    glutenenvy

    Joined:
    Sep 6, 2011
    Location:
    WA
    #16
    Bad power causes all kinds of both temporary and permanent problems. Surge suppressing power strips fail over time and only protect you from spikes but not brownouts. If your computer still powers up, it sounds like a ups would be a good investment at your location. If it doesn't power up anymore, a ups would be a good investment for your next computer.
     
  17. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #17
    Suggesting Tuxera is contributing to the problems.

    As noted, it may be loaded on-demand. Furthermore, you'd be able to read NTFS, even without Tuxera.

    If by "since this", you mean "after plugging in the external drive and confirming it reads & writes". If that's the situation, then Tuxera has been loaded on-demand, and could be contributing to the problem.

    Did you do a complete system reinstall without Tuxera? If you only relied on its uninstaller, I would not assume that's identical to a clean newly installed baseline system. There could be leftovers that cause instability.

    In any case, Tuxera seems to have some problems with Mtn Lion, per this post by GGJstudios:
    http://forums.macrumors.com/showpost.php?p=15961726
    Some have reported problems using Tuxera (approx $36), which is an enhanced version of NTFS-3G with faster performance.


    I assume the reason you're using NTFS at all is for Windows compatibility of the external drive. Unless it's a bootable Windows drive, you might be better off using exFAT instead of NTFS. It's read/writable on OS X without any external file-system extensions.
     
  18. MitchAustralia thread starter macrumors newbie

    MitchAustralia

    Joined:
    Oct 6, 2012
    #18
    Okay, thanks for that info. Everything is powering up fine, I believe it's because the power board has always been very "loose", in that some of the plugs tend to just sit in the socket and wobble around.. not good. I'll have a look at a UPS.

    Yes, that is what happened the first time I booted into safe mode, so that would suggest Tuxera has something to do with it. However, I then uninstalled Tuxera and MacFuse, and restarted normally, and then shut down and booted into safe mode a second time, but the thumb drives still didn't work properly.

    No, I only uninstalled Tuxera and restarted as prompted. Hopefully there was still leftovers. Any ideas on how to completely get rid of it from the system? Yeah that's exactly why I am using it, but will soon be getting a My Book for Mac, allowing me to get rid of the software..[/QUOTE]
     
  19. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #19
    I hope there wasn't leftovers.

    I don't know any way to remove it, and know for certain it's completely removed. Nor do I know of no way to evaluate whether the uninstaller is completely removing the software or not.

    The usual reccommendation is to install a perfectly clean original OS, and then not install the thing you want to be rid of. I know of no way other than a completely clean OS install that absolutely ensures something won't be there. Prevention is certain (not installing it at all); any cure (removal after installing) is uncertain.

    Most external disk drives can be formatted to anything: exFAT, HFS+, any number of Linux-compatible file-systems, etc.

    If you have enough free disk space on other devices, you could:
    1. Copy the contents of the Maxtor external drive to that free space.
    2. Erase/initialize the Maxtor to the exFAT format.
    3. Copy the files back to the Maxtor.

    I don't know if this would make the Maxtor unusable as a Windows boot disk. If that doesn't matter to you, then it might be worth a try, though the amount of time it takes is going to depend on how full the Maxtor is.

    In any case, if Tuxera hasn't been completely and certainly eliminated from the OS, there's no guarantee that exFAT will solve any problem.
     

Share This Page